问题描述
有一个学校的老师共用N个教室,按照规定,所有的钥匙都必须放在公共钥匙盒里,老师不能带钥匙回家。每次老师上课前,都从公共钥匙盒里找到自己上课的教室的钥匙去开门,上完课后,再将钥匙放回到钥匙盒中。
钥匙盒一共有N个挂钩,从左到右排成一排,用来挂N个教室的钥匙。一串钥匙没有固定的悬挂位置,但钥匙上有标识,所以老师们不会弄混钥匙。
每次取钥匙的时候,老师们都会找到自己所需要的钥匙将其取走,而不会移动其他钥匙。每次还钥匙的时候,还钥匙的老师会找到最左边的空的挂钩,将钥匙挂在这个挂钩上。如果有多位老师还钥匙,则他们按钥匙编号从小到大的顺序还。如果同一时刻既有老师还钥匙又有老师取钥匙,则老师们会先将钥匙全还回去再取出。
今天开始的时候钥匙是按编号从小到大的顺序放在钥匙盒里的。有K位老师要上课,给出每位老师所需要的钥匙、开始上课的时间和上课的时长,假设下课时间就是还钥匙时间,请问最终钥匙盒里面钥匙的顺序是怎样的?
输入格式
输入的第一行包含两个整数N, K。
接下来K行,每行三个整数w, s, c,分别表示一位老师要使用的钥匙编号、开始上课的时间和上课的时长。可能有多位老师使用同一把钥匙,但是老师使用钥匙的时间不会重叠。
保证输入数据满足输入格式,你不用检查数据合法性。
输出格式
输出一行,包含N个整数,相邻整数间用一个空格分隔,依次表示每个挂钩上挂的钥匙编号。
样例输入
5 2
4 3 3
2 2 7
样例输出
1 4 3 2 5
样例说明
第一位老师从时刻3开始使用4号教室的钥匙,使用3单位时间,所以在时刻6还钥匙。第二位老师从时刻2开始使用钥匙,使用7单位时间,所以在时刻9还钥匙。
每个关键时刻后的钥匙状态如下(X表示空):
时刻2后为1X345;
时刻3后为1X3X5;
时刻6后为143X5;
时刻9后为14325。
样例输入
5 7
1 1 14
3 3 12
1 15 12
2 7 20
3 18 12
4 21 19
5 30 9
样例输出
1 2 3 5 4
评测用例规模与约定
对于30%的评测用例,1 ≤ N, K ≤ 10, 1 ≤ w ≤ N, 1 ≤ s, c ≤ 30;
对于60%的评测用例,1 ≤ N, K ≤ 50,1 ≤ w ≤ N,1 ≤ s ≤ 300,1 ≤ c ≤ 50;
对于所有评测用例,1 ≤ N, K ≤ 1000,1 ≤ w ≤ N,1 ≤ s ≤ 10000,1 ≤ c ≤ 100。
本体就是一个纯模拟题,用三个优先队列分别存取操作,放操作,和现在剩余的位置(由小到大排序)。
除了最后一个操作,前两个操作都可以用结构体排序来做。
code:
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
struct Time{
int start, end;
int bianhao;
}t;
struct cmp1
{
bool operator () (Time a,Time b)
{
return a.start>b.start;
}
};
struct cmp2
{
bool operator () (Time a,Time b)
{
if(a.end<b.end)
{
return false;
}
else if(a.end==b.end)
{
if(a.bianhao<b.bianhao)
{
return false;
}
else
{
return true;
}
}
else
{
return true;
}
}
};
int wei[1010];
int ans[1010];
int main(int argc, char** argv) {
priority_queue<int, vector<int>, greater<int> > res;
priority_queue<Time,vector<Time>, cmp1 > p;
priority_queue<Time,vector<Time>, cmp2 > q;
while(!p.empty())
{
p.pop();
}
while(!q.empty())
{
q.pop();
}
while(!res.empty())
{
res.pop();
}
int n,k;
cin>>n>>k;
for(int i=1;i<=n;i++)
{
wei[i]=i;
}
for(int i=0;i<k;i++)
{
int w,s,c;
cin>>w>>s>>c;
t.bianhao=w;
t.start=s;
t.end=c+s;
p.push(t);
q.push(t);
}
/*
while(!q.empty())
{
cout<<q.top().bianhao<<endl;
q.pop();
}*/
while(!p.empty())
{
Time a,b;
a=p.top();
b=q.top();
if(a.start<b.end)
{
res.push(wei[a.bianhao]);
p.pop();
//printf("jie : %d\n",a.bianhao);
}
else
{
wei[b.bianhao]=res.top();
//printf("huan : %d\n",b.bianhao);
res.pop();
q.pop();
}
}
while(!q.empty())
{
wei[q.top().bianhao]=res.top();
//printf("huan : %d\n",q.top().bianhao);
res.pop();
q.pop();
}
for(int i=1;i<=n;i++)
{
ans[wei[i]]=i;
}
for(int i=1;i<n;i++)
{
printf("%d ",ans[i]);
}
printf("%d\n",ans[n]);
return 0;
}