poj-3461Oulipo


Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35893 Accepted: 14488

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

    刚学的kmp,虽然是基础题目,但也是学了1天的成果,有详细的说明

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
char w[10000+11];
char t[1000000+11];
int next[10000+11];
void get_next()
{
	next[1]=0;
	int i=2,j,lenw=strlen(w);//i=2因为后缀最少是2,相对应的前缀是1 
	for(j=0;i<lenw;++i)
	{
		while(j>0&&w[i]!=w[j+1])
			j=next[j];
		if(w[i]==w[j+1])
			++j;
		next[i]=j; 
	//这里包含2中情况j=0;如果匹配,那next[i]=j+1=1;如果不匹配代表着w[i]和第一个都不匹配,直接
//next[i]=0;执行i++;知道找到与 j+1=1匹配的i值,当然前面不匹配的就直接赋值为0 ;j!=0那就直接next[i]=j
//因为在while循环里已经找到了匹配的情况 
	}
}
int times_kmp()
{
	int ans=0,i,j;
	int lenw=strlen(w),lent=strlen(t);
	for(i=1,j=0;i<lent;++i)
	{
		while(j>0&&t[i]!=w[j+1])
			j=next[j];
		if(t[i]==w[j+1])
			++j;
		if(j==lenw-1)
		{
			++ans;
			j=next[j];//其实到这里已经匹配完了,这时候的模拟串已经完了,这时候(你就假设后面还有
			//并且和目标串i+1肯定不匹配,因为模拟串都不知道是谁,你怎么匹配,那就回溯吧) 
		}
	}
	return ans;
}
int main()
{
	int text;
	scanf("%d",&text);
	getchar();
	while(text--)
	{
		int i=1,j=1;
		char ch;
		memset(w,'\0',sizeof(w));//这个是必须要处理的,因为上次的数据没办法清除 
		memset(t,'\0',sizeof(t));
		while((ch=getchar())!='\n')
			w[i++]=ch;
		while((ch=getchar())!='\n')
			t[j++]=ch;
		w[0]='*';t[0]='*';//这个是什么都行,但不要是'\0';
		get_next();
		int ans=times_kmp();
		printf("%d\n",ans);
	}
	return 0;
}</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值