hdoj-【5776 Sum】

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1637    Accepted Submission(s): 647


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 , 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
存在能整除m的子序列,在子序列的前面的数字和对m取余的值一定等于子序列 后面数字和对m取余的值,需要注意的特殊情况 当刚开始的一个序列就是m的倍数,而后面的 序列和并不是m的倍数,这就是一个bug,只需要让vis[0]=1即可
#include<cstdio>
#define maxn 200000
int vis[maxn];
int a[maxn],sa[maxn]; 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,n,m,flag=0;
		scanf("%d%d",&n,&m);
		for(i=1;i<m;++i)
			vis[i]=0;
		vis[0]=1;
		sa[0]=0; 
		for(i=1;i<=n;++i)
		{
			scanf("%d",&a[i]);
			a[i]%=m;
			sa[i]=(a[i]+sa[i-1])%m; 
			if(vis[sa[i]])
				flag=1;
			vis[sa[i]]=1; 	
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n"); 
	}
	return 0; 
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值