lightoj-【Consistent Verdicts】

37 篇文章 0 订阅
15 篇文章 0 订阅
Consistent Verdicts
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

In a 2D plane N persons are standing and each of them has a gun in his hand. The plane is so big that the persons can be considered as points and their locations are given as Cartesian coordinates. Each of the N persons fire the gun in his hand exactly once and no two of them fire at the same or similar time (the sound of two gun shots are never heard at the same time by anyone so no sound is missed due to concurrency). The hearing ability of all these persons is exactly same. That means if one person can hear a sound at distance R1, so can every other person and if one person cannot hear a sound at distance R2 the other N-1 persons cannot hear a sound at distance R2 as well.

The N persons are numbered from 1 to N. After all the guns are fired, all of them are asked how many gun shots they have heard (not including their own shot) and they give their verdict. It is not possible for you to determine whether their verdicts are true but it is possible for you to judge if their verdicts are consistent. For example, look at the figure above. There are five persons and their coordinates are (1, 2), (3, 1), (5, 1), (6, 3) and (1, 5) and they are numbered as 1, 2, 3, 4 and 5 respectively. After all five of them have shot their guns, you ask them how many shots each of them have heard. Now if there response is 1, 1, 1, 2 and 1 respectively then you can represent it as (1, 1, 1, 2, 1). But this is an inconsistent verdict because if person 4 hears 2 shots then he must have heard the shot fired by person 2, then obviously person 2 must have heard the shot fired by person 1, 3 and 4 (person 1 and 3 are nearer to person 2 than person 4). But their opinions show that Person 2 says that he has heard only 1 shot. On the other hand (1, 2, 2, 1, 0) is a consistent verdict for this scenario so is (2, 2, 2, 1, 1). In this scenario (5, 5, 5, 4, 4) is not a consistent verdict because a person can hear at most 4 shots.

Given the locations of N persons, your job is to find the total number of different consistent verdicts for that scenario. Two verdicts are different if opinion of at least one person is different.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing a positive integer N (1 ≤ N ≤ 700). Each of the next N lines contains two integers xi yi (0 ≤ xi, yi ≤ 30000) denoting a co-ordinate of a person. Assume that all the co-ordinates are distinct.

Output

For each case, print the case number and the total number of different consistent verdicts for the given scenario.

Sample Input

2

3

1 1

2 2

4 4

2

1 1

5 5

Sample Output

Case 1: 4

Case 2: 2

     有时候真理摆在你的面前你却看不到,按照思路这个问题
我们算出来每一个点到其他点的距离,我们把所有的距离从小
到大排列一下,从小到大一个个把距离都取出来,比较每一个点
小于这个距离有多少个点,比较所有的点就是一个方案!我当时
分析到这里竟然不会了,其实现在答案已经出来了,每一个距离
就代表一种方案,对不对?想一想,我们只需要把重复的距离去除
就是答案了。

 

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
double x[1000],y[1000];
double dis[300000]; 
double get_dis(double a,double b,double c,double d)
{
	return sqrt((a-c)*(a-c)+(b-d)*(b-d)); 
} 
int main()
{
	int t,test=1;
	scanf("%d",&t);
	while(t--)
	{
		int n,i,j;
		scanf("%d",&n);
		for(i=0;i<n;++i)
			scanf("%lf%lf",&x[i],&y[i]);
		int k=0;
		for(i=0;i<n;++i)
		{
			for(j=i+1;j<n;++j)
				dis[k++]=get_dis(x[i],y[i],x[j],y[j]); 
		}
		sort(dis,dis+k);
		int sum=unique(dis,dis+k)-dis;
		printf("Case %d: %d\n",test++,sum+1);
	} 
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值