node.js 运行时报错"Command failed with exit code 1."

node.js 运行时报错"Command failed with exit code 1."

问题描述

  • 今天运行本地项目,出现以下界面:

在这里插入图片描述
由上可知,好像是webpack-cli的模块从webpack-dev-server里面分离出来了,所以需要安装webpack-cli

  • 然后就根据提示,使用"yarn add -D webpack-cli"安装webpack-cli包之后,再次运行此项目,就会出现以下的报错:

在这里插入图片描述

解决办法

1.卸载web-cli,然后恢复老版本

我查看之前gitee.com上面的代码对比问题的package.json文件,webpack-dev-server之前是2.9.1
版本的,是可以正常运行的,安装3.1.10版本的就需要下载webpack-cli,所以应该是3.0以上的版本进行分离的,所以安装3.0以下的版本是可以的.
在这里插入图片描述

©️2020 CSDN 皮肤主题: 像素格子 设计师:CSDN官方博客 返回首页