Tree

                                                               Tree

原题链接 https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=489

 You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input

3 2 1 4 5 7 6

3 1 2 5 6 7 4

7 8 11 3 5 16 12 18

8 3 11 7 16 18 12 5

255

255

Sample Output

1

3

255

找到后序数组的最后一个元素。并以其为为根据,将中序数组分成左子树和右子树。以中序数组的左子树右子树为根据,将后序数组分为左子树和右子树。将中序左子树,后序左子树作为一个新的中序数组和后序数组,进行递归。
同时将新根数的根赋值给先前根的左儿子。同样方法处理右子树。
 

#include<stdio.h>
#include<sstream>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 10010
using namespace std;

int n,best_sum,best;
int in_order[MAXN],post_order[MAXN]/*中后序保存数组*/,Lch[MAXN],Rch[MAXN]/*二叉树左右数组*/;

int read_list(int *a)//读入每一行数据并用数组保存
{
    string line;//使用string构建line容器
    if(!getline(cin,line))
    {
        return 0;
    }
    stringstream ss(line);
    n=0;
    int x;
    while(ss>>x)
    {
        a[n++]=x;
    }
    return n>0;
}

//递归生成二叉树
int build(int l1,int r1,int l2,int r2)
{
    if(l1>r1)//判断是否为空树
    {
        return 0;
    }
    int  p=l1,root=post_order[r2];
    while(in_order[p]!=root)
    {
        p++;
    }
    int ANS=p-l1;//左子树的节点数量
    Lch[root]=build(l1,p-1,l2,l2+ANS-1);//生成左子树
    Rch[root]=build(p+1,r1,l2+ANS,r2-1);//右子书
    return root;
}

void dfs(int u,int v)
{
    v+=u;
    //通过判断语句,处理没有儿子时的指针赋空问题和递归基线问题。
    if(!Lch[u]&&!Rch[u])
    {
        if(v<best_sum||(v==best_sum&&u<best))
        {
            best=u;
            best_sum=v;
        }
    }
    if(Lch[u])
    {
        dfs(Lch[u],v);
    }
    if(Rch[u])
    {
        dfs(Rch[u],v);
    }
}

int main()
{
    while(read_list(in_order))
    {
        read_list(post_order);
        build(0,n-1,0,n-1);//开始构建二叉树
        best_sum=1000000000;
        dfs(post_order[n-1],0);//深搜遍历
        cout<<best<<"\n";
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值