Anniversary party

                                               Anniversary party

原题链接 http://poj.org/problem?id=2342

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

动态规划。有n个人开一个party,编号1到n,每个人都有一个欢乐值和一个直接上司,为了让气氛更high,要求从这n个人中选出一些人去参加party,并且选出的这些人中任意两个人之间必须没有直接上司或直接下属的关系,求出最大欢乐值。可以将这n个人通过直接上司或直接下属的关系构建一棵树,把父节点看做直接上司,子节点为下属,上司和下属不能同时选择。dp[i][0] 为第i个人不选择所获得的最大欢乐值,dp[i][1] 为第i个人被选择时所获得的最大欢乐值。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAXN 10000
using namespace std;

int n,flag;
int a[MAXN],vis[MAXN],dp[MAXN][2];

void init()//数组初始化
{
    memset(a,0,sizeof a);
    memset(dp,0,sizeof dp);
    memset(vis,0,sizeof vis);
}

void dfs(int t)
{
    vis[t]=1;
    for(int i=1; i<=n; i++)
    {
        if(!vis[i]&&a[i]==t)
        {
            dfs(i);
            dp[t][1]+=dp[i][0];//t来,就是他的直系下属不来的情况。
            dp[t][0]+=max(dp[i][0],dp[i][1]);//t不来,就是他的直系下属来或者不来的情况,选择最大值。
        }
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        init();
        flag=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);//边缘初始化(每个节点的权值)
        }
        int aa,bb;
        while(1)
        {
            scanf("%d%d",&aa,&bb);
            if(aa==0&&bb==0)
            {
                break;
            }
            a[aa]=bb;
            flag=bb;
        }
        dfs(flag);
        int ans=max(dp[flag][0],dp[flag][1]);//判断最大值
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值