HDU 1004.Let the Balloon Rise【找出出现次数最多的字符串】

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 98469    Accepted Submission(s): 37708


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
 
总结:

    本题题意很清楚,就是【找出出现次数最多的字符串】。

1.首先要注意的是,涉及到字符串的题目,都要加#include<string.h>这个头文件(要加.h哦);

2.把出现的各个颜色用【二维数组】存起来,并且对每个颜色的出现次数都要做一个统计用cnt[1000];

3.第一遍输入时,要先输入第一个颜色,后面每输入一个颜色,都要与之前的i-1个作比较,如果出现相同的,cnt[i]++;

4.最后一步,求出最大的cnt[i],通过遍历加一个if(>)的条件,求出max,同时用position记录出其位置。 

5.用scanf、printf输出字符串时用“%s”。

代码如下: 

#include <iostream>

#include <stdio.h>
#include <string.h>
using namespace std;


int main()
{
    char color[1000][16];
    int n, i, j, cnt[1000];
    int xmax, pos;
    while(scanf("%d", &n) != EOF)
    {
        if(n)
        {
            cnt[0] = 0;
            scanf("%s", color[0]);
            for(i=1; i<n; i++)
            {
                cnt[i] = 0;
                scanf("%s", color[i]);
                for(j=0; j<i-1; j++)
                {
                    if(strcmp(color[i],color[j])==0)
                        cnt[i] += 1;
                }
            }
            xmax = 0;
            pos = 0;
            for(i=1; i<n; i++)
            {
                if(xmax < cnt[i])
                {
                    xmax = cnt[i];
                    pos = i;
                }
            }
            printf("%s\n",&color[pos]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值