HDU.1019Least Common Multiple【深搜求最小公倍数】(3.13)

目描 述:
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.  

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.  

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 
Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
  
  
105 10296

【代码如下】

#include <iostream>

#include <stdio.h>
#include <string>


using namespace std;


int LCM(int x, int y)
{
    int z=x;
    int ans;
    while(x%y != 0)
    {
        x+=z;
    }
    ans = x;
    return ans;
}//求最小公倍数:x是几个数中最大的,先把x的值赋给z,如果x不能整除a[i],那么就把x翻倍,直到可以整除a[i],最后把x的值赋给ans,也就是传过来的当前这两个数的最小公倍数。
int main()
{
    int N, n;
    cin>>N;
    while(N--)//以后凡是输入组数的,都用while“倒计时”;
    {
        int a[10000];
        int ans=0;
        scanf("%d", &n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>ans) ans=a[i];//把n个数输进数组a[i]中,并求出最大的,为下面做铺垫;
        }
        for(int i=0; i<n; i++)
            ans = LCM(ans,a[i]);//传说中的深搜,也就是一组一组的求最小公倍数;
        cout<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值