算法笔记 Problem G: 比较字符串

Description

输入两个字符串,比较两字符串的长度大小关系。

Input

输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。

Output

输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。

Sample Input 

2
abc xy
bbb ccc

Sample Output 

abc is longer than xy
bbb is equal long to ccc
#include<cstdio>
#include<cstring>
int main(){
    int m;
    scanf("%d",&m);//输入用例个数
    while(m--){//接下来有m行
        char str1[50]={};
        char str2[50]={};
        scanf("%s %s",str1,str2);
        int len1=strlen(str1);//获取字符串的长度
        int len2=strlen(str2);
        if(len1==len2){
            printf("%s is equal long to %s\n",str1,str2);
        }else if(len1>len2){
            printf("%s is longer than %s\n",str1,str2);
        }else{
            printf("%s is shorter than %s\n",str1,str2);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值