素数筛法 练习九度1056 1438

题目1056:最大公约数
题目描述:

输入两个正整数,求其最大公约数。

输入:

测试数据有多组,每组输入两个正整数。

输出:

对于每组输入,请输出其最大公约数。

样例输入:
49 14
样例输出:
7
#include <iostream>
#include<stdio.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */


int gcd(int a,int b)
{
	if(b==0)return a;
	else
	{
		return gcd(b,a%b);
	}
}
int main(int argc, char** argv) {
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		printf("%d\n",gcd(a,b));
	}
	return 0;
}
#include <iostream>
#include<stdio.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */


int gcd(int a,int b)
{
	while(b!=0)
	{
		int t=a%b;
		a=b;
		b=t;
	}
	return a;
}
int main(int argc, char** argv) {
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		printf("%d\n",gcd(a,b));
	}
	return 0;
}
题目1438:最小公倍数

时间限制:1 秒

内存限制:128 兆

特殊判题:

题目描述:

给定两个正整数,计算这两个数的最小公倍数。

输入:

输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数。

输出:

对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。

样例输入:
10 14
样例输出:
70
#include <iostream>
#include<stdio.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int gcd(int a,int b)
{
return b!=0?gcd(b,a%b):a;
}
int main(int argc, char** argv) {
int a,b;
while(scanf("%d%d",&a,&b)!=EOF)
{
printf("%d\n",a*b/gcd(a,b));
}
return 0;
}

【九度OJ】题目1439:Least Common Multiple 解题报告

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:

2
3 5 7 15
6 4 10296 936 1287 792 1
  • 1
  • 2
  • 3
  • 4

样例输出:

105
10296

#include <iostream>
#include<stdio.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */


int gcd(int a,int b)
{
	return b!=0?gcd(b,a%b):a;
}
int buf[40];
int lcm(int a,int b)
{
	return a*b/gcd(a,b);
}
int main(int argc, char** argv) {
	int a,b;
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			int m;
			scanf("%d",&m);
			for(int j=0;j<m;j++)
			{
				scanf("%d",&buf[j]);
			}
			int tmp=1;
			for(int j=m-1;j>=0;j--)
			{
				tmp=lcm(buf[j],tmp);
			}
			printf("%d\n",tmp);
		}
	}
	return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值