搜索_IDA*_POJ2248_Addition Chains

原题:链接

Addition Chains

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5287 Accepted: 2842 Special Judge

Description

An addition chain for n is an integer sequence with the following four properties: 
  • a0 = 1 
  • am = n 
  • a0 < a1 < a2 < ... < am-1 < am 
  • For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable. 
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank. 
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space. 

Sample Input

5
7
12
15
77
0

Sample Output

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

题目大意:

给定一个数n,要找出一个最短的序列,满足:
1、第一个元素为1,最后一个元素为n
2、序列为升序
3、每个元素都是由它之前的两个元素(可以是同一元素)相加得到

AC代码:

#include <iostream>

using namespace std;

const int maxn = 105;
int a[maxn],r[maxn],b[2*maxn];
int n,ans;

void init(int n)
{
  ans = n;
  a[0]=1;

  //估价函数
  //b[i]表示当前数到最后一个数的理想最短距离
  for(int i=n;i<=2*n;i++)
    b[i]=0;
  for(int i=n-1;i>0;i--)
    b[i]=b[2*i]+1;
}

void print()
{
  for(int i=0;i<ans;i++)
    cout<<r[i]<<" ";
  cout<<n<<endl;
}

void dfs(int l)
{
  //用估价函数进行剪枝
  if(l+b[a[l]]>=ans)
    return;
  if(a[l]==n)
  {
    ans=l;
    for(int i=0;i<l;i++)
      r[i]=a[i];
    return;
  }
  for(int i=l;i>=0;i--)
    for(int k=i;k>=0;k--)
    {
      a[l+1]=a[i]+a[k];
      if(a[l+1]>a[l]&&a[l+1]<=n)
        dfs(l+1);
    }
}

int main()
{
  while(cin>>n)
  {
    if(n==0)
      break;
    init(n);
    dfs(0);
    print();
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值