POJ 3620 Avoid The Lakes【DFS水题练格式Avoid The Lakes Time Limit: 1000MS Memory Limit: 65536K Total Sub】

DFS 水题

原题链接:http://poj.org/problem?id=3620

我的链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=19651#problem/B

Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5563 Accepted: 2995

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

Source

DFS水题 开始居然没有看懂题意 Orz 就当练手了吧。

题意:给出一个矩阵,其中有些格子干燥、有些潮湿。

      如果一个潮湿的格子的相邻的四个方向有格子也是潮湿的,那么它们就可以构成更大

      的湖泊,求最大的湖泊。

      也就是求出最大的连在一块儿的潮湿的格子的数目。

//288 KB	16 ms	C++	874 B	2013-03-02 18:52:46
#include<cstdio>
#include<cstring>

const int maxn = 110;

bool map[maxn][maxn]; //记录潮湿点 
int dir[4][2] = { 0,1, 0,-1, -1,0, 1,0 }; //方向 

int n, m, k;
int sum, result;

void dfs(int x, int y)
{
	sum++;
	if(!map[x][y]) return; //一旦在这一方向上不是潮湿的就退出 
	map[x][y] = false; //同时也是标记 
	
	for(int i = 0; i < 4; i++)
	{
		int next_x = x+dir[i][0];
		int next_y = y+dir[i][1];
		
		if(next_x >= 1 && next_x <= n && next_y >= 1 && next_y <=m && map[next_x][next_y])
			dfs(next_x, next_y);
	}	
}
int main()
{
	while(scanf("%d%d%d", &n, &m, &k) != EOF)
	{
		result = 0;
		memset(map,false,sizeof(map));
		
		for(int i = 1; i <= k; i++)
		{
			int x, y;
			scanf("%d%d", &x, &y);
			map[x][y] = true;
		}
		
		for(int i = 1; i <= n; i++)
		{
			for(int j = 1; j <= m; j++)
			{
				if(map[i][j])
				{
					sum = 0;
					dfs(i, j);
					result = result > sum ? result : sum;
				}
			}
		}
		
		printf("%d\n",result);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值