【HDOJ 4764】 Stone (博弈)

【HDOJ 4764】 Stone (博弈)

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1090    Accepted Submission(s): 761


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
  
  
1 1 30 3 10 2 0 0
 

Sample Output
  
  
Jiang Tang Jiang
 

写数字游戏 轮流写出小于n的一个数 数字要求递增 并且当前玩家写出的数与前一玩家写的数差值 <= k  写出n的输

可以转换为取石子(然而题目就是Stone 为了不太赤果果 给改编了下= =也醉了

因此 只要(n-1)为(k+1)的倍数 即后手始终可以达到 k+1 2*(k+1) 3*(k+1)....的状态 这样先手必输 其余状态先手可达n-1


代码如下:

#include <bits/stdc++.h>

using namespace std;

int main()
{

	int n,m,t,i,j,u,v,w;
	while(~scanf("%d %d",&n,&m) && n+m)
	{
		if((n-1)%(m+1)) puts("Tang");
		else puts("Jiang");
	}


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值