【POJ 1195】 Mobile phones (树状数组)

【POJ 1195】 Mobile phones (树状数组)


Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 16761 Accepted: 7713

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source



二维树状数组 一前光写过一维的 一开始写的是第二维树状数组 第一维暴力。。。跑了四千多。。

后来查了查第一维跟第二维一样 累加Lowbite即可 查询的时候用大矩阵减去上面横向矩阵和左面纵向 这样多减了左上角的小矩阵 再加上即可 速度快了好多

兴起封了个类玩。。


代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;

class Trie
{
public:
    Trie()
    {
        memset(tr,0,sizeof(tr));
    }
    void run(int t)
    {
        int a,b,c,d;
        if(!t)
        {
            scanf("%d",&a);
            n = a;
        }
        else if(t == 1)
        {
            scanf("%d %d %d",&a,&b,&c);
            Add(a+1,b+1,c);
        }
        else
        {
            scanf("%d %d %d %d",&a,&b,&c,&d);
            printf("%d\n",Sum(c+1,d+1)+Sum(a,b)-Sum(a,d+1)-Sum(c+1,b));
        }
    }
private:
    int tr[1033][1033],n;
    int Lowbite(int x)
    {
        return x&(-x);
    }
    void Add(int x,int y,int data)
    {
        int i,j;
        for(i = x; i <= n; i += Lowbite(i))
            for(j = y; j <= n; j += Lowbite(j))
                tr[i][j] += data;
    }
    int Sum(int x,int y)
    {
        int ans = 0;
        int i,j;
        for(i = x; i > 0; i -= Lowbite(i))
            for(j = y; j > 0; j -= Lowbite(j))
                ans += tr[i][j];
        return ans;
    }
};

int main()
{
    int t;
    Trie *tr = new Trie();
    while(~scanf("%d",&t) && t != 3)
    {
        tr->run(t);
    }
    return 0;
}

//原
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;

int tr[1033][1033],n;

int Lowbite(int x)
{
    return x&(-x);
}

void Add(int x,int y,int data)
{
    int i,j;
    for(i = x; i <= n; i += Lowbite(i))
        for(j = y; j <= n; j += Lowbite(j))
            tr[i][j] += data;
}

int Sum(int x,int y)
{
    int ans = 0;
    int i,j;
    for(i = x; i > 0; i -= Lowbite(i))
        for(j = y; j > 0; j -= Lowbite(j))
            ans += tr[i][j];
    return ans;
}

int main()
{
    int t,a,b,c,d;
    memset(tr,0,sizeof(tr));
    while(~scanf("%d",&t) && t != 3)
    {
        if(!t)
        {
            scanf("%d",&a);
            n = a;
        }
        else if(t == 1)
        {
            scanf("%d %d %d",&a,&b,&c);
            Add(a+1,b+1,c);
        }
        else
        {
            scanf("%d %d %d %d",&a,&b,&c,&d);
            printf("%d\n",Sum(c+1,d+1)+Sum(a,b)-Sum(a,d+1)-Sum(c+1,b));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值