7-2 实验9_3_字母统计 (100分)

7-2 实验9_3_字母统计 (100分)
任意给定一个字符串,字符串中包含除了空格、换行符之外的的任意字符。你的任务是统计出现在该字符串中的各字母(即“A—Z”,“a—z”)的个数(区分大小写)。

输入格式:
一个长度不超过100的非空字符串。字符串中不会出现空格、换行符。

输出格式:
字符串中出现的字母的统计信息,每个字母的统计信息占一行,按照字母的ASCII码的顺序输出。。

输入样例:
AAAsdf&^%DF879as
输出样例:
注意单词“time”不论单复数,一律输出复数形式“times”

The character A has presented 3 times.
The character D has presented 1 times.
The character F has presented 1 times.
The character a has presented 1 times.
The character d has presented 1 times.
The character f has presented 1 times.
The character s has presented 2 times.

#include<stdio.h>
#include<string.h>
int main()
{
	char ch[100], st;
	int a[100] = { 0 }, b[100] = { 0 };
	int count1 = 0, count2 = 0, count3 = 0, count4 = 0, i = 0, j;
	scanf("%s",ch);
	while (ch[i] != 0)
	{
		if (ch[i] >= 'a'&&ch[i] <= 'z')
		{
			count1 = ch[i] - 'a';
			a[count1]++;

		}
		if (ch[i] >= 'A'&&ch[i] <= 'Z')
		{
			count2 = ch[i] - 'A';

			b[count2]++;
		}
		i++;
	}
 
	for (j = 0; j <= 25; j++)
	{
		if (b[j] != 0)
			printf("The character %c has presented %d times.\n", (char)('A' + j), b[j]);
	}
	for (j = 0; j <= 25; j++)
	{
		if (a[j] != 0)
			printf("The character %c has presented %d times.\n", (char)('a' + j), a[j]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ChaoYue_miku

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值