Hello XTCPC
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 981 Accepted Submission(s): 271
Problem Description
You have a string of lowercase letters.You need to find as many sequence “xtCpc” as possible.But letters in the same position can only be used once。
Input
The input file contains two lines.
The first line is an integer n show the length of string.(1≤n≤2×105)
The second line is a string of length n consisting of lowercase letters and uppercase letters.
Output
The input file contains an integer show the maximum number of different subsequences found.
Sample Input
10 xtCxtCpcpc
Sample Output
2
Source
原来题目是JSCPC,被改成了XTCPC
直接遍历一遍就OK了,但是要循环输入(题目里也没说啊)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 200005
int a[5];
int main()
{
char s[N];
int n;
while(~scanf("%d%s",&n,&s)){
memset(a,0,sizeof(a));
for(int i=0;i<n;++i){
if(s[i]=='x') a[0]++;
else if(s[i]=='t'){
if(a[0]){
a[1]++, a[0]--;
}
}else if(s[i]=='C'){
if(a[1]){
a[2]++, a[1]--;
}
}else if(s[i]=='p'){
if(a[2]){
a[3]++, a[2]--;
}
}else if(s[i]=='c'){
if(a[3]){
a[4]++, a[3]--;
}
}
}
cout<<a[4]<<endl;
}
return 0;
}