数据结构实验之链表五:单链表的拆分

 

数据结构实验之链表五:单链表的拆分

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6 
1 3 15 999 9 1001

Hint

不得使用数组!

Source

#include <bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    node *next;
};

node *head, *head1, *head2;
int head1_cnt, head2_cnt;

//void add(int num, node *head);
void print(node *head);  //打印
void make()  //  拆分
{
    node *p,*tail1,*tail2;
    head1 = new node;
    head2 = new node;
    head1->next = NULL;
    head2->next = NULL;

    p = head->next;
    tail1 = head1;
    tail2 = head2;

    while (p)
    {
        if (p->data %2 == 0)
        {
            tail1->next = p;
            tail1 = p;
            p = p->next;
            tail1->next = NULL;
            head1_cnt++;
        }
        else
        {
            tail2->next = p;
            tail2 = p;
            p = p->next;
            tail2->next = NULL;
            head2_cnt++;
        }

    }
}


int main()
{
    int n, num;
    node *tail, *p;
    head = new node;
    head->next = NULL;
    tail = head;

    cin >> n;
    for (int i=0; i<n; i++)
    {
        cin >> num;
        p= new node;
        p->data = num;
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
    head1_cnt = 0;
    head2_cnt = 0;


    make();

    cout << head1_cnt << " " << head2_cnt << endl;

    print(head1);
    print(head2);
    return 0;
}

void print(node *head)
{
    node *p;
    p = head->next;
    while (p)
    {
        if (p->next == NULL)
            cout << p->data << endl;
        else
            cout << p->data << " ";
        p = p->next;
    }
}


/***************************************************
User name: jk180602
Result: Accepted
Take time: 0ms
Take Memory: 192KB
Submit time: 2019-03-04 19:46:29
****************************************************/

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值