走迷宫
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
有一个m*n格的迷宫(表示有m行、n列),其中有可走的也有不可走的,如果用1表示可以走,0表示不可以走,输入这m*n个数据和起始点、结束点(起始点和结束点都是用两个数据来描述的,分别表示这个点的行号和列号)。现在要你编程找出所有可行的道路,要求所走的路中没有重复的点,走时只能是上下左右四个方向。如果一条路都不可行,则输出相应信息(用-1表示无路)。
Input
第一行是两个数m,n(1< m, n< 15),接下来是m行n列由1和0组成的数据,最后两行是起始点和结束点。
Output
所有可行的路径,输出时按照左上右下的顺序。描述一个点时用(x,y)的形式,除开始点外,其他的都要用“->”表示。如果没有一条可行的路则输出-1。
Sample Input
5 4 1 1 0 0 1 1 1 1 0 1 1 0 1 1 0 1 1 1 1 1 1 1 5 4
Sample Output
(1,1)->(1,2)->(2,2)->(2,3)->(3,3)->(3,2)->(4,2)->(4,1)->(5,1)->(5,2)->(5,3)->(5,4) (1,1)->(1,2)->(2,2)->(2,3)->(3,3)->(3,2)->(4,2)->(5,2)->(5,3)->(5,4) (1,1)->(1,2)->(2,2)->(3,2)->(4,2)->(4,1)->(5,1)->(5,2)->(5,3)->(5,4) (1,1)->(1,2)->(2,2)->(3,2)->(4,2)->(5,2)->(5,3)->(5,4) (1,1)->(2,1)->(2,2)->(2,3)->(3,3)->(3,2)->(4,2)->(4,1)->(5,1)->(5,2)->(5,3)->(5,4) (1,1)->(2,1)->(2,2)->(2,3)->(3,3)->(3,2)->(4,2)->(5,2)->(5,3)->(5,4) (1,1)->(2,1)->(2,2)->(3,2)->(4,2)->(4,1)->(5,1)->(5,2)->(5,3)->(5,4) (1,1)->(2,1)->(2,2)->(3,2)->(4,2)->(5,2)->(5,3)->(5,4)
Hint
Source
#include <bits/stdc++.h>
using namespace std;
int gra[16][16], vis[16][16];
int X[400], Y[400]; // 记录每一次点的坐标
int dirx[] = {0, -1, 0, 1}; // 方向数组
int diry[] = {-1, 0, 1, 0};
int step, flag;
int startx, endx;
int starty, endy;
int n, m;
void print() {
for (int i = 0; i < step; i++) {
if (i == step - 1)
printf("(%d,%d)\n", X[i], Y[i]);
else
printf("(%d,%d)->", X[i], Y[i]);
}
}
void dfs(int x, int y) {
vis[x][y] = 1;
if (x < 1 || y < 1 || x > n || y > m) {
return;
}
if (x == endx && y == endy) {
flag = 1;
print();
return;
}
for (int i = 0; i < 4; i++) {
int a = x + dirx[i];
int b = y + diry[i];
if (!vis[a][b] && gra[a][b]) {
X[step] = a;
Y[step] = b;
step++;
dfs(a, b);
vis[a][b] = 0; // 回塑 取消标记
step--;
}
}
}
int main() {
int num;
cin >> n >> m;
memset(gra, 0, sizeof(gra));
memset(vis, 0, sizeof(vis));
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= m; j++) {
cin >> num;
gra[i][j] = num;
}
}
step = 0;
flag = 0;
cin >> startx >> starty;
cin >> endx >> endy;
// 起点初始化
X[0] = startx;
Y[0] = starty;
step++;
dfs(startx, starty);
if (!flag) cout << -1 << endl;
return 0;
}