文章标题

  1. Lenny’s Lucky Lotto
    Description
    Lenny likes to play the game of lotto. In the lotto game, he picks a list of N unique numbers in the range from 1 to M. If his list matches the list of numbers that are drawn, he wins the big prize.
    Lenny has a scheme that he thinks is likely to be lucky. He likes to choose his list so that each number in it is at least twice as large as the one before it. So, for example, if N = 4 and M = 10, then the possible lucky lists Lenny could like are:

1 2 4 8
1 2 4 9
1 2 4 10
1 2 5 10

Thus Lenny has four lists from which to choose.

Your job, given N and M, is to determine from how many lucky lists Lenny can choose.

Input
There will be multiple cases to consider from input. The first input will be a number C (0 < C <= 50) indicating how many cases with which you will deal. Following this number will be pairs of integers giving values for N and M, in that order. You are guaranteed that 1 <= N <= 10, 1 <= M <= 2000, and N <= M. Each N M pair will occur on a line of its own. N and M will be separated by a single space.
Output
For each case display a line containing the case number (starting with 1 and increasing sequentially), the input values for N and M, and the number of lucky lists meeting Lenny’s requirements. The desired format is illustrated in the sample shown below.
Sample Input
Copy sample input to clipboard
3
4 10
2 20
2 200
Sample Output
Case 1: n = 4, m = 10, # lists = 4
Case 2: n = 2, m = 20, # lists = 100
Case 3: n = 2, m = 200, # lists = 10000

#include <iostream>
#include <cstring>
#include <cmath>

using namespace std;

int main(int argc, char **argv)
{
    int cases;
    int N, M;
    cin >> cases;
    long long arr[11][3000];
    int k;
    for  (k = 1; k <= cases; k++) {
        cin >> N >> M;
        memset(arr, 0, sizeof(arr));
        int i , j;
        for (i = 1; i <= M; i++) {
            arr[1][i] = 1;
        }
        for (i = 2; i <= N; i++) {
            for (j = 1; j <= M; j++) {
                if (j % 2 == 0) arr[i][j] = arr[i][j-1] + arr[i-1][j/2];
                else arr[i][j] = arr[i][j-1];
            }
        }
        long long sum = 0;
        for (i = 1; i <= M; i++) {
            sum += arr[N][i];
        }
        cout << "Case " << k << ": n = " << N << ", m = " << M << ", # lists = " << sum << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值