解决几个rime的诡异现象

我使用明月拼音的语句流+简体

1.出现了这样的情况,明月拼音-语句流不支持词库,明月拼音-简体不支持模糊音。

而两个配置文件除了词库名字不一样外,几乎一模一样,(配置文件是我在网上下载别人的)


最终解决:luna_pinyin_simp.custom.yaml文件中有两个patch:,(注意一个补丁文件中,只能有一个patch命令)导致打补丁出错了,但是补丁部分可以用,语句流中应该是加载词库时由于多了一个patch而出错。

明月拼音-简体是加载到模糊音配置时出错

至于为啥出错的地方不一样,我也不知道,总是删掉一个patch,这两个问题都解决了


2.我向symbols文件中加了几个自定义,为了在重新配置时不被重置,将该文件重命名为tanzi_symbols.yaml

起初我以为可以加载多个symbol文件,就在luna_pinyin_simp.custom.yaml中

  "punctuator/import_preset": symbols #开启symbols.yaml,可以用/FH等输入特殊符号。

改为了

  "punctuator/import_preset": symbols,tanzi_symbols #开启symbols.yaml,可以用/FH等输入特殊符号。

重新配置

额,发现词库和模糊音都不能用了,赶紧改回来

再重新配置

好,灵异事件发生了,居然还是词库和模糊音都不能用,讲道理是回到操作前的状态呀!!

经过一番周折,我发现了,我的配置文件luna_pinyin_simp.custom.yaml中有两个patch,删掉一个。

重新配置

ok,完美解决


说明:

其实,这两个问题是同一个bug导致,我一周前出现了问题1,我折腾了很久,没解决。今天碰到了问题2,卧操,这样,模糊音和词库都不能用,那这个输入法就废了嘛!

删掉一个patch语句(也可以用#注释掉)后,两个问题都解决了,好开心!


没有更多推荐了,返回首页