Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 38391 | Accepted: 12478 |
Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li(1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
Output
Sample Input
3 8 5 8
Sample Output
34
Hint
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
Source
朴素的HuffmanTree思想是:
(1)先把输入的所有元素升序排序,再选取最小的两个元素,把他们的和值累加到总费用
(2)把这两个最小元素出队,他们的和值入队,重新排列所有元素,重复(1),直至队列中元素个数<=1,则累计的费用就是最小费用
用这个方法做,每次取完两个最小的相加后再放回进行排序,时间复杂度很高,会超时。
可以用priority_queue或是multiset来实现。
priority_queue实现代码:
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 150005;
int main(void)
{
int n;
while(~scanf("%d", &n))
{
priority_queue<long long, vector<long long>, greater<long long> >pq;
unsigned long long ans = 0;
for(int i = 0; i < n; i++)
{
long long t;
scanf("%lld", &t);
pq.push(t);
}
while(1)
{
long long a = pq.top(); pq.pop();
long long b = pq.top(); pq.pop();
pq.push(a+b);
ans += a+b;
if(pq.size() == 1)
{
printf("%lld\n", ans);
break;
}
}
}
return 0;
}
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<set>
using namespace std;
const int maxn = 150005;
int main(void)
{
int n;
while(~scanf("%d", &n))
{
multiset<int>s;
unsigned long long ans = 0;
for(int i = 0; i < n; i++)
{
long long t;
scanf("%lld", &t);
s.insert(t);
}
while(1)
{
long long a = *(s.begin()); s.erase(s.begin());
long long b = *(s.begin()); s.erase(s.begin());
s.insert(a+b);
ans += a+b;
if(s.size() == 1)
{
printf("%lld\n", ans);
break;
}
}
}
return 0;
}