PAT How Long Does It Take (25) (拓扑排序)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (<=100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N-1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
Sample Output 1:
18
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:

Impossible

拓扑排序定义:



算法:



该题代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 105;
int n, m, k, head[maxn];
struct node
{
	int u, v, w, next;
}edge[maxn];

struct node2
{
	int degree, early;
}G[maxn];

void addEdge(int u, int v, int w)
{
	edge[k].v = v;
	edge[k].w = w;
	edge[k].next = head[u];
	head[u] = k++;
}

void topSort()
{
	queue<int> q;
	int count = 0;
	for(int i = 0; i < n; i++)
		if(G[i].degree == 0)
			q.push(i), count++;
	while(!q.empty())
	{
		int u = q.front(); q.pop();
		for(int t = head[u]; t != -1; t = edge[t].next)
		{
			int to = edge[t].v;
			int curEar = G[u].early;
			int nextEar = G[to].early;
			int cost = edge[t].w;
			G[to].early = max(nextEar, curEar+cost);
			if(--G[to].degree == 0)
				q.push(to), count++;
		}
	}
	
	if(count != n) puts("Impossible");
	else
	{
		int ans = -1;
		for(int i = 0; i < n; i++)
			ans = max(ans, G[i].early);
		printf("%d\n", ans);
	}
}

int main(void)
{
	while(cin >> n >> m)
	{
		memset(G, 0, sizeof(G));
		memset(head, -1, sizeof(head));
		k = 0;
		while(m--)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			G[v].degree++;
			addEdge(u, v, w);
		}
		topSort();
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值