poj 1088滑雪(记忆化搜索, dp)

35 篇文章 1 订阅
滑雪
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 92465 Accepted: 34980

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source

SHTSC 2002


dp[i][j] = max(dp[i-1][j], dp[i+1][j], dp[i][j-1], dp[i][j+1]


代码一:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 105;
int a[maxn][maxn], dp[maxn][maxn], row, col, ans;

int dfs(int x, int y)
{
	if(dp[x][y]) return dp[x][y];
	int next[4][2] = {0, 1, 0, -1, 1, 0, -1, 0}, sum = 1;
	for(int i = 0; i < 4; i++)
	{
		int tx = x+next[i][0];
		int ty = y+next[i][1];
		if(tx >= 0 && ty >= 0 && tx < row && ty < col && a[tx][ty] < a[x][y])
			sum = max(sum, dfs(tx, ty)+1);
	}
	return dp[x][y] = sum;
}

int main(void)
{
	int t;
	cin >> t;
	while(t--)
	{
		scanf("%d%d", &row, &col);
		int ans = 1;
		for(int i = 0; i < row; i++)
			for(int j = 0; j < col; j++)
				scanf("%d", &a[i][j]);
		memset(dp, 0, sizeof(dp));
		for(int i = 0; i < row; i++)
			for(int j = 0; j < col; j++)
				if(!dp[i][j]) ans = max(ans, dfs(i, j));
		printf("%d\n", ans);
	}
	return 0;
}


代码二:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 105;
const int INF = 0x3f3f3f3f;
int a[maxn][maxn], dp[maxn][maxn], row, col, ans;

int dfs(int x, int y, int pre)
{
	if(x < 0 || y < 0 || x >= row || y >= col || a[x][y] >= pre) return 0;
	if(dp[x][y]) return dp[x][y];		//注意这句和前面那句不能颠倒顺序
	return dp[x][y] = max(max(dfs(x+1, y, a[x][y]), dfs(x-1, y, a[x][y])), max(dfs(x, y+1, a[x][y]), dfs(x, y-1, a[x][y])))+1;
}

int main(void)
{
	while(~scanf("%d%d", &row, &col))
	{
		int ans = 1;
		for(int i = 0; i < row; i++)
			for(int j = 0; j < col; j++)
				scanf("%d", &a[i][j]);
		memset(dp, 0, sizeof(dp));
		for(int i = 0; i < row; i++)
			for(int j = 0; j < col; j++)
				ans = max(ans, dfs(i, j, INF));
		printf("%d\n", ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值