virtual Judge 刷题 Red and Black

Red and Black

题目描述

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile.
From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

输出
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

样例输入

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

样例输出

45
59
6
13

题解思路
题目的大概意思就是,输入n列m行(用数组时行列要注意!),从符号‘@’开始,遇到’.‘可以走,遇到‘ # ’走不通,最后返回能走的‘.’步数是多少。

思路很简单,就是DFS(深度优先搜索)遍历整个图,遇到能走的就走同时总步数+1,不能走时回退到能走的地方再走,跟人走迷宫一个道理。

代码

#include<iostream>
using namespace std;

int m ,n ;//地图的行列
const int maxn = 21;
const int maxm = 21;
char map[maxn][maxm];	//地图
int dir[4][2] = {  { 0, 1 }, { 0, -1 },{ 1, 0 }, { -1, 0 } };	//用于移动的数组
int step; //能走的总步数

int dfs(int x,int y)
{
	map[x][y] = '#';	//将本位置置为# 省去了使用标记数组
	++step;	//可走,步数加1

	//cout << x << " " << y << endl; 这里可以输出走迷宫的过程,因题目需要就注释了

	for (int i = 0; i < 4; i++)	//遍历上下左右
	{
		int xx = x + dir[i][0], yy = y + dir[i][1];	//记录下一个位置的坐标

		if (map[xx][yy] == '.' && xx >= 0 && xx < m && yy >= 0 && yy < n) //看看是否能走 判断是否越界
		{
			dfs( xx, yy); //可以走就继续向前走
		}
		
	}
	
	return step; //返回步数	
}

int main()
{
	int xx, yy;
	while (cin >> n >> m && n && m)	//题目要求多组数据 以0 0输入为结束
	{
		for (int i = 0; i < m; i++) //注意输入的n,m跟循环的n,m的位置,对比题目,题目先输入的是数组的列!
		{
			for (int j = 0; j < n; j++)
			{
				cin >> map[i][j];	//输入地图
				
				if (map[i][j] == '@')	//同时记录起点的位置
				{
					xx = i;
					yy = j;
				}
			}
		}
		
		printf("%d\n", dfs(xx,yy)); //打印答案
		step = 0; //!!!一定要记得每完成一次要将步数重新置0
		
	}//while
	
	system("pause");
	return 0;
}

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值