1228: 字符统计
时间限制: 2 Sec 内存限制: 128 MB
提交: 919 解决: 443
[状态] [提交] [命题人:外部导入]
题目描述
给出一串字符,要求统计出里面的字母、数字、空格以及其他字符的个数。
字母:A, B, …, Z、a, b, …, z组成
数字:0, 1, …, 9
空格:" "(不包括引号)
剩下的可打印字符全为其他字符。
输入
测试数据有多组。
每组数据为一行(长度不超过100000)。
数据至文件结束(EOF)为止。
输出
每组输入对应一行输出。
包括四个整数a b c d,分别代表字母、数字、空格和其他字符的个数。
样例输入 Copy
A0 ,
ab12 4$
样例输出 Copy
1 1 1 1
2 3 1 1
这道题在写的时候,在多实例输入含空格的字符串是遇到了困难while(~scanf("%s",str))
这样的不能包含空格,因为空格和回车代表输入结束,而用
while(~gets(str))
会出现编译不通过的情况,经过向大佬请教发现这里的‘~’应该删去,这样题目就能A了,上代码
#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <queue>
#include <deque>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <string>
#include <cstring>
using namespace std;
int main()
{
char str[100005];
int a[27];
int b[11];
while(gets(str)) {
int first=0;
int second=0;
int third=0 ;
int fourth=0;
int len = strlen(str);
for(int i=0;i<len;i++){
if((str[i]>='a'&&str[i]<='z')||(str[i]>='A'&&str[i]<='Z'))
{
first++;
}
else if(str[i]>='0'&&str[i]<='9')
second++;
else if(str[i]==' ')
third++;
else
fourth++;
}
printf("%d %d %d %d\n",first,second,third,fourth);
}
return 0;
}