HDU 1425 sort

sort

Time Limit: 6000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 60210 Accepted Submission(s): 16618

Problem Description

给你n个整数,请按从大到小的顺序输出其中前m大的数。

Input

每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。

Output

对每组测试数据按从大到小的顺序输出前m大的数。

Sample Input

5 3
3 -35 92 213 -644

Sample Output

213 92 3

Hint

请用VC/VC++提交

Author

LL

题解

此题用桶排序即可。用两个数组分别存放正数和负数和0,用数组的下标表示这个数。代码如下:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <stack>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <utility>
#define ll long long

using namespace std ;

bool pos[500005] ;
bool neg[500005] ;

void init(){
    memset(pos , false , sizeof(pos)) ;
    memset(neg , false , sizeof(neg)) ;
    return ;
}

int main(){
    int n , m ;
    while ( scanf("%d%d" , &n , &m) != EOF ){
        init() ;
        for ( int i = 0 ; i < n ; i ++ ){
            int t ;
            scanf("%d" , &t) ;
            if ( t < 0 ){
                neg[-t] = true ;
            }else if ( t >= 0 ){
                pos[t] = true ;
            }
        }
        bool first = true ;
        for ( int i = 500000 ; i >= 0 ; i -- ){
            if ( pos[i] == true && m ){
                if ( first == true ){
                    printf("%d" , i) ;
                    first = false ;
                }else{
                    printf(" %d" , i) ;
                }
                m -- ;
            }
        }
        for ( int i = 1 ; i <= 500000 ; i ++ ){
            if ( neg[i] == true && m ){
                if ( first == true ){
                    printf("%d" , -i) ;
                    first = false ;
                }else{
                    printf(" %d" , -i) ;
                }
                m -- ;
            }
        }
        printf("\n") ;
    }
    return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值