HDU1024

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 … S x, … S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + … + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + … + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8

Hint
Huge input, scanf and dynamic programming is recommended.

最大N段连续子序列和:
这里写图片描述

dp[i][j]: 以j结尾的最大i段连续子序列和
temp[i][j]: j 之前的最大i段连续子序列和(记录j之前的最大值)
dp[i][j]:如果取dp[i][j-1]即把f[i]作为结尾添加到f[i-1]所在的一段,若取temp[i-1][j-1]即f[i]为新序列的开头

空间优化用一维数组:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1000000
#define INF 0x3f3f3f3f
int dp[maxn], f[maxn], temp[maxn];
int main()
{
    int m, n, i, j, k, ans;
    while(~scanf("%d %d",&m, &n)){
        for(i = 1; i <= n; ++i){
            scanf("%d",&f[i]);
        }
        memset(dp,0, sizeof(dp));
        memset(temp,0,sizeof(temp));
        for(i = 1; i <= m; ++i){
            ans = -INF;
            for(j = i; j <= n; ++j){
                if(i == j){
                    dp[j] = temp[j-1] + f[j];
                }
                else{
                    dp[j] = max(dp[j-1], temp[j-1]) + f[j];
                }
                temp[j-1] = ans;
                if(dp[j] > ans) ans = dp[j];
            }
        }
        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值