HDU1059 && POJ1014

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , … , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.
The last line of the input file will be “0 0 0 0 0 0”; do not process this line.
Output
For each collection, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

题目大意:
有六种石头价值分别为1、2、3、4、5、6
有两个人共同拥有一些石头,给出具体数量, 问他们能否把石头平分(两个人获得的价值相同,并且石头不能切开)

多重背包问题:
把这些石头价值总和的一半作为背包的容量, 如果能把恰能放满,则能平分。
如果石头的总价值为奇数那么肯定不能平分咯。

//闲话:注意边界值啊啊啊!!!!还有输出的”.”还有空行, 那个结构体用的也是挺多余的。QAQ

多重背包+二进制优化+拆解:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 150000
int dp[maxn];
struct marbles{
    int m,n;
};
int main()
{
    int num[7] = {0}, i, j , k,l, sum, time = 0, T_sum = 0;
    while(~scanf("%d %d %d %d %d %d", &num[1], &num[2], &num[3], &num[4], &num[5], &num[6])
            &&( num[1] || num[2] || num[3] || num[4] || num[5] || num[6])){
        ++time;
        printf("Collection #%d:\n",time);
        sum = 0;
        T_sum = 1;
        marbles mar[6];
        for(i = 1; i <= 6; ++i){
            sum += (num[i]*i);
            if(num[i] != 0){
                mar[T_sum].m = i;
                mar[T_sum].n = num[i];
                ++T_sum;
            }
        }
        if(sum%2 != 0){
            printf("Can't be divided.\n\n");
        }
        else{
            memset(dp,0,sizeof(dp));
            for(i = 1; i < T_sum; ++i){
                if(mar[i].m*mar[i].n >= sum/2){
                    for(l = mar[i].m; l <= sum/2; ++l){
                        dp[l] = max(dp[l], dp[l-mar[i].m]+mar[i].m);
                    }
                }
                else{
                    for(k = 1; k <= mar[i].n; k *=2){
                        for(j = sum/2; j >= mar[i].m*k; --j){
                            dp[j] = max(dp[j], dp[j - mar[i].m*k] + mar[i].m*k);
                        }
                        mar[i].n -= k;
                    }
                    if(mar[i].n > 0){
                        for(j = sum/2; j >= mar[i].m*mar[i].n; --j){
                            dp[j] = max(dp[j], dp[j - mar[i].m*mar[i].n] + mar[i].m*mar[i].n);
                        }
                    }
                }
            }
            if(dp[sum/2] == sum/2)
                printf("Can be divided.\n\n");
            else
                printf("Can't be divided.\n\n");
        }

    }
}

之前提到过的状态转移方程长得像→_→dp[l] = max(dp[l], dp[l-mar[i].m]+mar[i].m)物品容量与物品价值是相同的,这种都可以用这种方法。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 150000
int dp[maxn], temp[maxn];
struct marbles{
    int m,n;
};
int main()
{
    int num[7] = {0}, i, j , k,l, sum, time = 0, T_sum = 0;
    while(~scanf("%d %d %d %d %d %d", &num[1], &num[2], &num[3], &num[4], &num[5], &num[6])
            &&( num[1] || num[2] || num[3] || num[4] || num[5] || num[6])){
        ++time;
        printf("Collection #%d:\n",time);
        sum = 0;
        T_sum = 1;
        marbles mar[6];
        for(i = 1; i <= 6; ++i){
            sum += (num[i]*i);
            if(num[i] != 0){
                mar[T_sum].m = i;
                mar[T_sum].n = num[i];
                ++T_sum;
            }
        }
        if(sum%2 != 0){
            printf("Can't be divided.\n\n");
        }
        else{
            memset(dp,0,sizeof(dp));
            dp[0] = 1;
            for(i = 1; i < T_sum; ++i){
                memset(temp, 0, sizeof(temp));
                for(j = mar[i].m; j <= sum/2; ++j){
                    if(temp[j - mar[i].m] < mar[i].n && !dp[j] && dp[j-mar[i].m]){
                        dp[j] = 1;
                        temp[j] = temp[j-mar[i].m] + 1;
                    }
                }
            }

            if(dp[sum/2])
                printf("Can be divided.\n\n");
            else
                printf("Can't be divided.\n\n");
        }

    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值