算法竞赛进阶指南——畜栏预订

畜栏预订

题目链接

#include<iostream>
using namespace std;
#include<algorithm>
#include<set>
#include<queue>

/*
输入样例:
5
1 10
2 4
3 6
5 8
4 7
输出样例:
4
1
2
3
2
4
*/


const int N=50005;

typedef pair<int,int> PII;

pair<PII,int> cows[N];
/*
cows[i].first.first     记录区间开始位置 
cows[i].first.second    记录区间结束位置
cows[i].second          记录区间下标 
*/

int id[N];              //记录每头牛用那个槽 

int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>cows[i].first.first>>cows[i].first.second;
		cows[i].second=i;
	} 
	sort(cows,cows+n);//默认按照first排序 
	priority_queue<PII,vector<PII>,greater<PII> > heap;
	//heap 中每个元素都是一个pair pair第一个元素记录该槽的结束时间  第二个元素记录改槽是第几个槽 
	for(int i=0;i<n;i++)
	{
		if(heap.empty() || heap.top().first >= cows[i].first.first)
		{
			PII stall={cows[i].first.second,heap.size()+1};
			id[cows[i].second]=stall.second;
			heap.push(stall);
		}
		else
		{
			auto stall=heap.top();
			heap.pop();
			id[cows[i].second]=stall.second;
			stall.first=cows[i].first.second;
			heap.push(stall);
		}
	}
	cout<<heap.size()<<endl;
	for(int i=0;i<n;i++) cout<<id[i]<<endl;
	return 0; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值