hdu_problem_2070_Fibbonacci Number

/*
*Problem Description
*Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:
*
*f(0) = 0
*f(1) = 1
*f(n) = f(n-1) + f(n-2)
*
*Your program should be able to handle values of n in the range 0 to 50.
*
*
*Input
*Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
*
*
*Output
*Print out the answer in a single line for each test case.
*
*
*Sample Input
*3
*4
*5
*-1
*
*
*Sample Output
*2
*3
*5
*
*Hint
*Note:
*
*you can use 64bit integer: __int64
*
*
*Author
*Lily
*
*
*Source
*浙江工业大学网络选拔赛
*
*
*Recommend
*linle
*
*/
#include<iostream>
using namespace std;
_int64 fb_num[51] = { 0,1 };
void init() {
 for (int i = 2; i < 51; ++i) {
  fb_num[i] = fb_num[i - 1] + fb_num[i - 2];
 }
}
int main() {
 int x;
 init();
 while (cin >> x) {
  if (x == -1) break;
  cout << fb_num[x] << endl;
 }
 system("pause");
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值