Let it Bead (POJ - 2409) (polya计数原理)

题意:
“Let it Bead” company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It’s a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.
Input
Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.
Output
For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.
Sample Input
1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0
Sample Output
1
2
3
5
8
13
21
今天学习了传说中的polya,听说过好多次,今天终于亲身学习了。此题我第一次接触相关的题。
如果没有学习,这题的确还是挺难想,而polya就给我一种体系化的思考去解题了
对于此类问题
第一步一定要确定好置换的的种类,也就是置换群(我在第一步就出了问题…)
第二步确定每种置换的循环节个数
第三部就是套公式计算就是了
每一步都是后一步的基础.

这题我以为的置换只有只有旋转,而没有对换,所以从一开始就错了。
对于对换还有根据n的奇偶性分类讨论…
代码:

import java.util.Scanner;



public class Main 
{
    public static void main(String[]args)
    {
        Scanner sc=new Scanner(System.in);
        for(;;)
        {
            int c=sc.nextInt();
            int n=sc.nextInt();
            if(n==0&&c==0)
                break;
            long count=0;
            for(int i=1;i<=n;i++)
                count+=(long)Math.pow(c, gcd(i,n));//n种的旋转类的相应的循环节的个数
            if(n%2==1)//奇偶讨论
            {
                count+=Math.pow(c,(n+1)/2)*n;
            }
            else
            {
                count+=Math.pow(c, n/2+1)*n/2;
                count+=Math.pow(c, n/2)*n/2;
            }
            System.out.println(count/2/n);//所有一共是有2*n个不同的置换
        }
    }
    static int gcd(int a,int b)
    {
        return a%b==0? b:gcd(b,a%b);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值