(pat)A1030. Travel Plan

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output
0 2 3 3 40

评价:在最短路的基础上加了一些应用,实际上从起点开始还是从终点开始所求的答案是一样的,但是本题还要求路径,所以我们在进行松弛操作的时候,顺便更新是从哪个点转移的,这个只要一个next数组,如果我们从终点开始,就很容易了,从起点开始也可以就需要栈或者递归来输出路径了
ac代码

#include<iostream>
#include<cstdio>
#include<map> 
#include<vector>
#include<algorithm> 
#include<queue>
#include<cstring>
#define maxx 0x3f3f3f3f
using namespace std;

int n,m,s,e;
struct node
{
    int to;
    int w;
    int cost;
    node(int _to,int _w,int _cost):to(_to),w(_w),cost(_cost){}
};
vector<node> graph[505];
int dis[505];
int cost[505];
bool inQ[505];
void addEdge(int x,int y,int w,int cost)
{
    graph[x].push_back(node(y,w,cost));
    graph[y].push_back(node(x,w,cost));
}
int Next[505];

void spfa()
{
    memset(dis,maxx,sizeof(dis));
    dis[e]=0;
    cost[e]=0;
    inQ[e]=true;
    Next[e]=-1;
    queue<int> que;
    que.push(e);
    while(!que.empty())
    {
        int now=que.front();
        que.pop();
        inQ[now]=false;
        for(int i=0;i<graph[now].size();i++)
        {
            int v=graph[now][i].to;
            int w=graph[now][i].w;
            int c=graph[now][i].cost;
            if(dis[v]>dis[now]+w)
            {
                dis[v]=dis[now]+w;
                cost[v]=cost[now]+c;
                Next[v]=now;
                if(!inQ[v])
                {
                    que.push(v);
                    inQ[v]=true; 
                }
            }
            else
            {
                if(dis[v]==dis[now]+w&&cost[v]>cost[now]+c)
                {
                    cost[v]=cost[now]+c;
                    Next[v]=now;
                    if(!inQ[v])
                    {
                        que.push(v);
                        inQ[v]=true;
                    }
                }
            }
        }                                                                                                                                                                                                                                                                                                                     
    } 
}
int main()
{
    scanf("%d%d%d%d",&n,&m,&s,&e);
    int x,y,w,c;
    while(m--)
    {
        scanf("%d%d%d%d",&x,&y,&w,&c);
        addEdge(x,y,w,c); 
    }
    spfa();
    int temp=s; 
    while(temp!=-1)
    {
        printf("%d ",temp);
        temp=Next[temp];
    }
    printf("%d %d",dis[s],cost[s]); 
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值