An addition chain for n is an integer sequence with the following four properties:
a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj
You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.
Input
The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.
Sample Input
5
7
12
15
77
0
Sample Output
1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
实际上,因为每科搜索树的分支非常多,但是如果我们能找着答案在浅层的树上,我们就可用加深迭代,实质上就是枚举深度了就是。
代码:
#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
#include<iostream>
#include <cstring>
#define maxx 200005
using namespace std;
int ans[15];
int n;
bool sign;
bool dfs(int cur ,int limit)
{
if(cur==limit)
{
for(int i=cur-1;i>=0;i--)
{
for(int j=i;j>=0;j--)
if(ans[i]+ans[j]==n)
return true;
else
if(ans[i]+ans[j]<n)
return false;
}
}
char vis[105];
memset(vis,0,sizeof(vis));
for(int i=cur-1;i>=0;i--)
for(int j=i;j>=0;j--)
{
int temp=ans[i]+ans[j];
if(vis[temp]||temp>=n)
continue;
if(temp<=ans[cur-1])
break;
ans[cur]=temp;
if(!dfs(cur+1,limit))
vis[temp]=true;//因为不同值的加和的值可能会一样,但是如果之前出现过的找不到答案,那么我们就可用跳过这个值。
else
return true;
}
return false;
}
int main()
{
ans[0]=1;
ans[1]=2;
for(;;)
{
scanf("%d",&n);
if(!n)
break;
if(n==1)
{
cout<<"1"<<endl;
continue;
}
if(n==2)
{
cout<<"1 2"<<endl;
continue;
}
for(int i=2;i<=11;i++)
{
if(dfs(2,i))
{
for(int j=0;j<i;j++)
cout<<ans[j]<<" ";
cout<<n<<endl;
break;
}
}
}
return 0;
}