Ascending Rating【2018 Multi-University Training Contest 3 A题】(单调队列)

Problem Description
Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant’s QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m−1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=0 and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.

Input
The first line of the input contains an integer T(1≤T≤2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r,MOD≤109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,…,ak(0≤ai≤109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<in) a i ( k < i ≤ n ) are then produced as follows :
ai=(p×ai1+q×i+r)mod MOD a i = ( p × a i − 1 + q × i + r ) m o d   M O D

It is guaranteed that n7×107andk2×106 ∑ n ≤ 7 × 10 7 a n d ∑ k ≤ 2 × 10 6 .

Output
Since the output file may be very large, let’s denote maxratingi and counti as the result of interval [i,i+m−1].
For each test case, you need to print a single line containing two integers A and B, where :

A=nm+1i=1(maxratingii) A = ∑ i = 1 n − m + 1 ( m a x r a t i n g i ⊕ i )
B=nm+1i=1(countii) B = ∑ i = 1 n − m + 1 ( c o u n t i ⊕ i )

Note that “⊕” denotes binary XOR operation.

Sample Input
1
10 6 10 5 5 5 5
3 2 2 1 5 7 6 8 2 9

Sample Output
46 11
不应该,一直想从前往后,没想到从后往前,可能最近数论做多了,脑子短路
代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#include<cmath>
#define maxx 10000005
#define ll long long
using namespace std;
int a[maxx];
int que[maxx];
int main()
{
    int t;
    cin>>t;
    int n,m,k,p,q,r,mod;
    while(t--)
    {
        scanf("%d%d%d%d%d%d%d",&n,&m,&k,&p,&q,&r,&mod);
        for(int i=1;i<=k;i++)
            scanf("%d",a+i);
        r%=mod;
        for(int i=k+1;i<=n;i++)
            a[i]=((ll)p*a[i-1]%mod+(ll)q*i%mod+r)%mod;
        int L=0,R=0;
        ll ans1=0;
        ll ans2=0;
        for(int i=n;i>=n-m+1;i--)
            if(L==R)que[R++]=i;
            else
            {
                while(L<R&&a[que[R-1]]<=a[i])R--;
                que[R++]=i;
            }
        ans1+=(n-m+1)^a[que[L]];
        ans2+=(n-m+1)^(R-L);
        //cout<<a[que[L]]<<" "<<(R-L)<<endl;
        for(int i=n-m;i>=1;i--)
        {
            if(L==R)
                que[R++]=i;
            else
            {
                while(L<R&&a[que[R-1]]<=a[i])R--;
                que[R++]=i;
                while(L<R&&que[L]-que[R-1]+1>m)L++;
            }
            ans1+=i^a[que[L]];
            ans2+=i^(R-L);
        }
        printf("%lld %lld\n",ans1,ans2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值