HDU 4800 Josephina and RPG(DP)

Josephina and RPG

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2349    Accepted Submission(s): 711
Special Judge

 

Problem Description

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.
Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.
The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams.
Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

 

 

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

 

 

Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

 

 

Sample Input

 

4 0.50 0.50 0.20 0.30 0.50 0.50 0.90 0.40 0.80 0.10 0.50 0.60 0.70 0.60 0.40 0.50 3 0 1 2

 

 

Sample Output

 

0.378000

 

据说是简单DP好吧,想了很久

1.dp[i][j]表示的是第i轮中用第j个队伍的最大胜率

2.那么我们可以想一下对于每个队伍J有两种方案,要么是乘前面换的,要么乘不换的,但是我们规定当前打败ai的队伍一定是J队伍,那么对于每个J队伍,如果上一次击败的是ai'(j)队伍,那么可以变换,如果上次击败的不是ai(J)队伍,那么当前J队伍只能不换,再仔细想想,我们可以发现每一轮,规定是某个队伍击败Ai后,其实只有一个队伍可以进行变换(即 击败的Ai与自己的队伍编号相同的)

3.所以每次的最优解都是当前轮,每个队伍击败Ai的最大概率

4.写dp容易掉头发

#include <stdio.h>
#include<string.h>
#include<algorithm> 
using namespace std;
double map[261][261];
double dp[10010][261];
int main(int argc, char *argv[])
{
	int m;
	while(scanf("%d",&m)!=EOF)
	{
		m=m*(m-1)*(m-2)/6;
		int i,j;
		for(i=0;i<m;i++)
		{
			for(j=0;j<m;j++)
			{
				scanf("%lf",&map[i][j]);			
			}
		}	
		for(i=0;i<m;i++)
		{
			dp[0][i]=1;
		}		
		int n;
		scanf("%d",&n);
		double change;	
		for(i=1;i<=n;i++)
		{
			int enemy;
			scanf("%d",&enemy);
	  		change=0;
			for(j=0;j<m;j++)
			{
				dp[i][j]=dp[i-1][j]*map[j][enemy];
				change=max(change,dp[i][j]);	
			}
			dp[i][enemy]=change;
		}
		printf("%.6lf\n",change);
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值