Thanks to a certain “green” resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water’s surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of ‘#’ represents an oily cell, and a character of ‘.’ represents a pure water cell.
Output
For each case, one line should be produced, formatted exactly as follows: “Case X: M” where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
Sample Input
1
6
…
.##…
.##…
…#.
…##
…
Sample Output
Case 1: 3
题目的意思:’#'是石油,有个人挖石油,采集石油的工具可以覆盖一个10米乘20米的长方形,采集时工具不能碰到海水,每一格长10米,二分匹配
主要问题是将二分图构建出来,剩下的就简单多了
上代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char map[1000][1000];
int book[1000],match[1000],e[1010][1010],num[1010][1010],number,to[4][2]={0,1,0,-1,1,0,-1,0},n,m;
int dfs(int u)
{
for(int i=0;i<number;i++)
{
if(e[u][i]==1&&book[i]==0)
{
book[i]=1;
if(match[i]==0||dfs(match[i]))
{
match[i]=u;
return 1;
}
}
}
return 0;
}
int main()
{
int k,v=1;
scanf("%d",&k);
while(k--)
{
memset(map,0,sizeof(map));
memset(e,0,sizeof(e));
int i,j;
number=0;
scanf("%d",&n);
getchar();
for(i=0;i<n;i++)
{
gets(map[i]);
for(j=0;j<n;j++)
{
if(map[i][j]=='#')
num[i][j]=number++;
}
}
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
if(map[i][j]=='#')
{
for(int k=0;k<4;k++)
{
int x=i+to[k][0];
int y=j+to[k][1];
if(x>=0&&y>=0&&x<n&&y<n&&map[x][y]=='#')
{
int n1=num[i][j];
int n2=num[x][y];
e[n1][n2]=1;
}
}
}
}
}
//
// for(int i=0;i<number;i++)
// {
// for(int j=0;j<number;j++)
// printf("%d",e[i][j]);
// printf("\n");
// }
//
//
//
memset(match,0,sizeof(match));
int sum=0;
for(i=0;i<number;i++)
{
memset(book,0,sizeof(book));
if(dfs(i))
sum++;
}
printf("Case %d: %d\n",v++,sum/2);
}
return 0;
}