Oil Skimming(二分图最大匹配)

Thanks to a certain “green” resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water’s surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of ‘#’ represents an oily cell, and a character of ‘.’ represents a pure water cell.
Output
For each case, one line should be produced, formatted exactly as follows: “Case X: M” where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
Sample Input
1
6

.##…
.##…
…#.
…##

Sample Output
Case 1: 3

题目的意思:’#'是石油,有个人挖石油,采集石油的工具可以覆盖一个10米乘20米的长方形,采集时工具不能碰到海水,每一格长10米,二分匹配
主要问题是将二分图构建出来,剩下的就简单多了
上代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char map[1000][1000];
int book[1000],match[1000],e[1010][1010],num[1010][1010],number,to[4][2]={0,1,0,-1,1,0,-1,0},n,m;
int dfs(int u)
{
	for(int i=0;i<number;i++)
	{
		if(e[u][i]==1&&book[i]==0)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int k,v=1;
	scanf("%d",&k);
	while(k--)
	{
		memset(map,0,sizeof(map));
		memset(e,0,sizeof(e));
		int i,j;
		number=0;
	
		scanf("%d",&n);
			getchar();
		for(i=0;i<n;i++)
		{
			gets(map[i]);
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='#')
					num[i][j]=number++;
			}
		}
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='#')
				{
					for(int k=0;k<4;k++)
					{
						int x=i+to[k][0];
						int y=j+to[k][1];
						if(x>=0&&y>=0&&x<n&&y<n&&map[x][y]=='#')
						{
							int n1=num[i][j];
							int n2=num[x][y];
							e[n1][n2]=1;
						}
					}
				}
			}
		}
//		
//		for(int i=0;i<number;i++)
//		{
//			for(int j=0;j<number;j++)
//		printf("%d",e[i][j]);
//		printf("\n");
//		}
//		
//		
//		
		
		memset(match,0,sizeof(match));
		int sum=0;
		for(i=0;i<number;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;
		}	
		printf("Case %d: %d\n",v++,sum/2);
	} 
	return 0;
}
《RSMA与速率拆分在有限反馈通信系统中的MMSE基预编码实现》 本文将深入探讨RSMA(Rate Splitting Multiple Access)技术在有限反馈通信系统中的应用,特别是通过MMSE(Minimum Mean Square Error)基预编码进行的实现。速率拆分是现代多用户通信系统中一种重要的信号处理策略,它能够提升系统的频谱效率和鲁棒性,特别是在资源受限和信道条件不理想的环境中。RSMA的核心思想是将用户的数据流分割成公共和私有信息两部分,公共信息可以被多个接收器解码,而私有信息仅由特定的接收器解码。这种方式允许系统在用户间共享信道资源,同时保证了每个用户的个性化服务。 在有限反馈通信系统中,由于信道状态信息(CSI)的获取通常是有限且不精确的,因此选择合适的预编码技术至关重要。MMSE预编码是一种优化策略,其目标是在考虑信道噪声和干扰的情况下最小化期望平方误差。在RSMA中,MMSE预编码用于在发射端对数据流进行处理,以减少接收端的干扰,提高解码性能。 以下代码研究RSMA与MMSE预编码的结合以观察到如何在实际系统中应用RSMA的速率拆分策略,并结合有限的反馈信息设计有效的预编码矩阵。关键步骤包括: 1. **信道模型的建立**:模拟多用户MIMO环境,考虑不同用户之间的信道条件差异。 2. **信道反馈机制**:设计有限反馈方案,用户向基站发送关于信道状态的简化的反馈信息。 3. **MMSE预编码矩阵计算**:根据接收到的有限反馈信息,计算出能够最小化期望平方误差的预编码矩阵。 4. **速率拆分**:将每个用户的传输信息划分为公共和私有两部分。 5. **信号发射与接收**:使用预编码矩阵对信号进行处理,然后在接收端进行解码。 6. **性能评估**:分析系统吞吐量、误码率等性能指标,对比不同策略的效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值