[ACM_ZOJ_1002]Fire Net

Fire Net

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.


Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:
5
1
5
2
4

Source
ZOJ1002

这道题去年的时候跟@SamuelCanDoIt 一起做过,当时还不懂神马叫回溯,只是单纯地用递归做,未能解决该问题。。可惜当时的幼稚代码已经找不到了,当时具体的思路是这样的,从数组左上角开始递归,把左上角1*1的部分当成一个1*1的Fire Net问题,确定是否能放置碉堡,若能则标记为已放置,然后进入下层递归,将左上角2*2的部分作为一个2*2的Fire Net问题,由于左上角的位置已经确定是否放置,因此以此来确定最后一列及最后一行的放置情况,以此类推。后来终于明白为什么这种方法未能得出正确的结果,是因为某一个位置虽然可以放置碉堡,但可能该位置不放置碉堡的情况是最优解,而这种方法没有考虑到这种情况。

该题正确解法如下(回溯):

#include<stdio.h>
#include<cmath>
char net[4][5];
int max = 0;
bool allow(int n, int row, int col){
	if(net[row][col] == 'X'){
		return false;
	}
	int i;
	for(i = row; i >= 0; --i){	//向前遍历该列
		if(net[i][col] == '@')	//若该列防止过碉堡
			return false;	//则该位置不能放置
		else if(net[i][col] == 'X')	//若遇到墙
			break;	//跳出循环遍历开始行
	}
	for(i = col; i >= 0; --i){	//向前遍历该行
		if(net[row][i] == '@')	//同上
			return false;
		else if(net[row][i] == 'X')
			break;
	}
	return true;
}
void BackTrack(int n, int k, int num){
	if(k == n * n){
		if(num > max){
			max = num;
		}
		return;
	}
	int row = k / n, col = k % n;	//由k得出行列坐标
	if(allow(n, row, col)){
		net[row][col] = '@';	//标志为'@'以说明该位置放置了碉堡
		BackTrack(n, k + 1, num + 1);	//放置碉堡后进入下层递归
		net[row][col] = '.';	//可能该位置不放置碉堡的情况可得出最优解
	}
	BackTrack(n, k + 1, num);	//不放置碉堡进入下层递归
}
int main(){
	int n, i;
	while(scanf("%d", &n) && n){
		max = 0;
		for(i = 0; i < n; ++i){
			scanf("%s", net[i]);
		}
		BackTrack(n, 0, 0);
		printf("%d\n", max);
	}
	return 0;
}




=======================签 名 档=======================
原文地址(我的博客):http://www.clanfei.com/2012/03/339.html
欢迎访问交流,至于我为什么要多弄一个博客,因为我热爱前端,热爱网页,我更希望有一个更加自由、真正属于我自己的小站,或许并不是那么有名气,但至少能够让我为了它而加倍努力。。
=======================签 名 档=======================



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值