hdoj1054 Strategic Game(二分图最大匹配求最小点覆盖)

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8181    Accepted Submission(s): 3911


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1068  1150  1151  1281  1142
题意:很明显是要求最小点覆盖数,既假设选择了一个点就覆盖了这个点连接的所有边,要选出最少的点覆盖所有边。
由此涉及到二分图的最大匹配数,链接入口http://www.cnblogs.com/kuangbin/archive/2012/08/26/2657446.html
此题可作为求二分图最大匹配数的模板。
注:显然,树就是一种特殊的二分图。
代码如下:
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string>
using namespace std;
vector<int> v[1505];
int flag[1505];
int linker[1505];
int n;
int dfs(int u)
{
	for(int i=0;i<v[u].size();i++)
	{
		if(!flag[v[u][i]])
		{
			flag[v[u][i]]=1;
			if(linker[v[u][i]]==-1||dfs(linker[v[u][i]]))
			{
				linker[v[u][i]]=u;return 1;
			}
		}
	}
	return 0;
}
int hungry()
{
	int res=0;
	memset(linker,-1,sizeof(linker));
	for(int u=0;u<n;u++)
	{
		memset(flag,0,sizeof(flag));
		if(dfs(u))res++;
	}
	return res;	
}
int main()
{
	int node,sum,id;
	int i,j,k;
	while(~scanf("%d",&n))
	{
	    for(i=0;i<n;i++)v[i].clear();
		for(i=0;i<n;i++)
		{
			scanf("%d:(%d)",&node,&sum);
			for(j=0;j<sum;j++){scanf("%d",&id);v[node].push_back(id);v[id].push_back(node);}
		}		
	printf("%d\n",hungry()/2);
				
	}
        return 0;	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值