Power Strings

题目:

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.


分析:

题目介绍了一大堆看起来很唬人,但是只是要求循环节的出现的次数,用“Next 数组”公式就OK了,记得先进行判断是否是循环。


代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int Next[100000005];
char str[100000005];

void get_next(){
    int len = strlen(str);
    int j = 0, k = -1;
    Next[0] = -1;
    while(j < len){
        if(k == -1 || str[j] == str[k]){
            k++;
            j++;
            Next[j] = k;
        }
        else
            k = Next[k];
    }
}

/*
int kmp(){
    int i = 0, j = 0;
    while(i < a_len && j < b_len){
        if(j == -1 || a[i] == b[j]){
            i++;
            j++;
        }
        else
            j = Next[j];
    }
    if(j == b_len)
        return i - j + 1;
    else
        return -1;
}
*/

int main(){
    int t;
    while(scanf("%s", str) && str[0] != '.'){
        get_next();
        int len = strlen(str);
        if(len % (len - Next[len]) == 0)
            cout << len/(len - Next[len]) << endl;
        else
            cout << "1" << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值