PAT A 1086(甲级)

1086 Tree Traversals Again(25 分)

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

 


 

这道题关键的问题是读懂题目的意思,首先第一句话的意思很关键,二叉树的中序遍历可以用栈这种非递归的方式来执行。也就是说栈的输入输出顺序等埋藏着中序遍历的线索。

然后再看题目中的举例,通过对栈的push和pop来唯一确定了一棵树,我们观察可以发现push的顺序也就是这棵树的先序遍历的顺序,那么pop的顺序是不是中序遍历呢,经过验证我们发现是这样的。

所以我们就可以根据题目输入的push pop来得到一棵树的先序和中序遍历,从而得到题目中最终要求的后序遍历。

具体的求法类似于 PAT A 1020 如果不会的话可以参考一下。

 


 

AC代码:

#include <cstdio>
#include <string.h>
#include <stack>

using namespace std;

struct Tree {
    int data;
    Tree * lchild, * rchild;
};

int pre[50], in[50];
int prenum = 0, innum = 0;
bool first = false;

Tree* createTree(int, int, int, int);
void postTravel(Tree *);

int main() {
    int n;
    stack<int> s;
    char order[20];

    scanf("%d", &n);
    for(int i = 0; i < 2 * n; ++i) {
        scanf("%s", order);
        if(strcmp(order, "Push") == 0) {
            int index;
            scanf("%d", &index);
            pre[prenum++] = index;
            s.push(index);
            while(getchar() != '\n') {
                continue;
            }
        }
        if(strcmp(order, "Pop") == 0) {
            in[innum++] = s.top();
            s.pop();
        }
    }

    Tree * root = createTree(0, n - 1, 0, n - 1);
    postTravel(root);

    return 0;
}

Tree* createTree(int prel, int prer, int inl, int inr) {
    if(inl > inr) {
        return NULL;
    }

    Tree * t = new Tree;
    t->data = pre[prel];

    int i;
    for(i = inl; i < inr; ++i) {
        if(in[i] == pre[prel]) {
            break;
        }
    }

    int numleft = i - inl;
    t->lchild = createTree(prel + 1, prel + numleft, inl, i - 1);
    t->rchild = createTree(prel + numleft + 1, prer, i + 1, inr);

    return t;
}

void postTravel(Tree * root) {
    if(root == NULL) {
        return ;
    }

    postTravel(root->lchild);
    postTravel(root->rchild);
    if(first) {
        printf(" ");
    }
    printf("%d", root->data);
    first = true;
}

 


 

如有错误,欢迎指摘。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值