PAT A 1013(甲级)

1013 Battle Over Cities(25 分)

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing Knumbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

 


 

这道题其实是在变相的让读者求去掉某个点之后,会形成多少个不连通的区域,n个不连通的区域至少需要n - 1一个边才能完全连接。

这道题使用BFS或者DFS都可以,都可以达到计算连通块数量的目的,但是一定要记住不要将被占领点计算在内。

 

或者使用并查集也可以求解这道题,将图构建完成之后,再根据去掉的点不同分别构建并查集,最后计算有几个为father的节点,就是有几个连通块。

 

下面只给出BFS求解的方法。

 


 

AC代码:

#include <cstdio>
#include <string.h>
#include <queue>

using namespace std;

const int maxn = 1010;

int n, m, k, ocu;
int G[maxn][maxn] = {0}, con[maxn];
bool vis[maxn] = {0};

void calRepair();
void bfs(int);

int main() {
    scanf("%d%d%d", &n, &m, &k);
    for(int i = 0; i < m; ++i) {
        int u, v;
        scanf("%d%d", &u, &v);
        G[u][v] = 1;
        G[v][u] = 1;
    }

    for(int i = 0; i < k; ++i) {
        scanf("%d", con + i);
    }

    for(int i = 0; i < k; ++i) {
        ocu = con[i];
        calRepair();
    }

    return 0;
}

void calRepair() {
    memset(vis, 0, sizeof(vis));
    int region = 0;
    for(int i = 1; i <= n; ++i) {
        if(i != ocu && !vis[i]) {
            bfs(i);
            ++region;
        }
    }


    printf("%d\n", region - 1);
}

void bfs(int v) {
    queue<int> qg;
    vis[v] = true;
    qg.push(v);

    while(qg.size() != 0) {
        int a = qg.front();
        qg.pop();

        for(int i = 1; i <= n; ++i) {
            if(i != ocu && !vis[i] && G[a][i] == 1) {
                qg.push(i);
                vis[i] = true;
            }
        }
    }
}

 


 

如有错误,欢迎指摘。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值