【PAT 甲级】1011 World Cup Betting (20)

1011 World Cup Betting (20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and Lfor lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

 

我的思路

虽然英文题目一开始没看懂,但是看数据和公式就明白是怎么个套路了。

找出每行最大的数,并记录该数的下标 0/1/2。

 

注意事项

关于奇怪的保留两位小数.2f自动四舍五入,查看了这篇文章,决定采用+0.001的方法。

 

我的代码

一开始直接就想着找最大值,然后用if else记录对应W T L。

#include <cstdio>

//找出三个数中最大值的函数 
double max(double a, double b, double c)
{
	double M;
	if (a>=b)
	{
		if (a>=c)
		{
			printf("W ");
			M = a;
		} else {
			printf("L ");
			M = c;
		}
	} else {
		if (b>=c)
		{
			printf("T ");
			M = b;
		} else {
			printf("L ");
			M = c;	
		}
	}
	return M;
}

//主函数 
int main()
{
	double W, T, L, sum=1.0;
	for (int i=1; i<=3; i++)
	{
		scanf ("%lf %lf %lf", &W, &T, &L);
		sum *= max(W,T,L);
	}
	sum = (sum*0.65-1.0)*2.0 + 0.001;  //加0.001便于四舍五入 
	printf("%.2lf", sum);
	return 0;
} 

后来看了《算法笔记》,确实存成数组,用下标找会更简便:

#include <cstdio>

int main()
{
	double t, max, sum=1.0;
	int j, flag;
	char n[]={'W','T','L'};
	for (int i=0; i<3; i++)
	{
		max = 0.0;
		for (j=0; j<3; j++)
		{
		    scanf ("%lf", &t);
			if (t>max)
			{
				max = t;
				flag = j;
			}	
		}
		sum *= max;
		printf("%c ", n[flag]);
	}
	sum = (sum*0.65-1.0)*2.0 + 0.001;  //加0.001便于四舍五入 
	printf("%.2lf", sum);
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值