【PAT 甲级】1058 A+B in Hogwarts (20 分)

1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

我的思路

主要就是读懂英文,然后暴力模拟。

“Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle” 就是17个银西克兑一个加隆,29个纳特兑一个西克。

 

我的代码

#include <cstdio>
int main()
{
	int g1,g2,s1,s2,k1,k2;
	int k,s,g;
	scanf("%d.%d.%d %d.%d.%d", &g1,&s1,&k1,&g2,&s2,&k2);
	k = (k1+k2)%29;
	s = ((k1+k2)/29 + s1 + s2)%17;
	g = ((k1+k2)/29 + s1 + s2)/17 + g1 + g2;
	printf("%d.%d.%d",g,s,k);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值