二叉树的遍历(递归)

1058: 二叉树遍历

时间限制: 1 Sec  内存限制: 128 MB
提交: 18  解决: 8
[ 提交][ 状态][ 讨论版]

题目描述

对于二叉树T,可以有先序遍历、中序遍历和后序遍历三种遍历方式。现在我们要求给出一棵二叉树的先序遍历序列和中序遍历序列,输出它的广度优先遍历序列。 

输入

第一行为一个整数t(0<t<10),表示测试用例个数。 以下t行,每行输入一个测试用例,包含两个字符序列s1和s2,其中s1为一棵二叉树的先序遍历序列,s2为中序遍历序列。s1和s2之间用一个空格分 隔。序列只包含大写字母,并且每个字母最多只会出现一次。

输出

为每个测试用例单独一行输出广度优先遍历序列。

样例输入

2DBACEGF ABCDEFGBCAD CBAD

样例输出

DBEACGFBCAD

提示

本题主要测试对二叉树遍历的理解。需要先根据先序序列和中序序列建立二叉树,然后对二叉树进行按层次的遍历。




AC源码:

#include <iostream>
#include <queue>
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;
struct node
{
	char value;
	node* lft;
	node* rgt;
	node(char v):value(v),lft(0),rgt(0){}
};

node* build_tree(vector<char> x,vector<char> y)
{
	if(x.empty()&&y.empty())
		return nullptr;
	node* root=new node(x.front());
	vector<char> A1,A2,B1,B2;
	int cnt=0;
	while(y[cnt]!=x.front())
		cnt++;
	for(int i=1;i<=cnt;++i)
		A1.push_back(x[i]);
	for(int i=0;i<cnt;++i)
		A2.push_back(y[i]);
	for(int i=cnt+1;i<x.size();++i)
		B1.push_back(x[i]);
	for(int i=cnt+1;i<y.size();++i)
		B2.push_back(y[i]);
	root->lft=build_tree(A1,A2);
	root->rgt=build_tree(B1,B2);
	return root;
}
void bfs(node* root)
{
	queue<node*> que;
	que.push(root);
	while(!que.empty())
	{
		auto nd=que.front();que.pop();
		cout<<nd->value;
		if(nd->lft)
			que.push(nd->lft);
		if(nd->rgt)
			que.push(nd->rgt);
	}
}
int T;
int main()
{
	cin>>T;
	while(T--)
	{
		vector<char> x,y;
		char s1[30],s2[30];
		scanf("%s %s",s1,s2);
		for(int i=0;s1[i];i++)
			x.push_back(s1[i]);
		for(int i=0;s2[i];i++)
			y.push_back(s2[i]);
		node* root=build_tree(x,y);
		bfs(root);
		cout<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值