1105 Spiral Matrix(25 分)(cj)

1105 Spiral Matrix(25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

怎么写一个 可以打印矩形 好看又整洁的代码 这么难。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <algorithm>
#include <math.h>
using namespace std;
vector<int> varr;
int map[200][200];
int idex = 0;
int deal(int n);
void printmatrix(int row, int col);
bool cmp(const int& a, const int& b);
int main() {
	int n, x;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		varr.push_back(x);
	}
	sort(varr.begin(), varr.end(), cmp);
	int col = deal(n), row = n / col;
	printmatrix(row, col);
	for (int i = 0; i < row; ++i) {
		for (int j = 0; j < col; ++j) {
			if (j != 0) cout << ' ';
			cout << map[i][j];
		}
		cout << endl;
	}
	system("pause");
	return 0;
}
bool cmp(const int& a, const int& b) {
	return a > b;
}
int deal(int n) {
	int i;
	for (i = sqrt(n); i > 0; --i) {
		if (n%i == 0) break;
	}
	return i;
}
void printmatrix(int m, int n) {
	int x = 0, y = 0;
	while (1) {
		int i = x, j = y;
		if (idex == varr.size() - 1) {
			map[i][j] = varr[idex++];
			return;
		}
		while (j+1 < n) {
			map[i][j] = varr[idex++];
			++j;
			if (idex == varr.size()) return;
		}
		while (i+1 < m) {
			map[i][j] = varr[idex++];
			++i;
			if (idex == varr.size()) return;
		}
		while (j-1 >= y) {
			map[i][j] = varr[idex++];
			--j;
			if (idex == varr.size()) return;
		}
		while (i-1 >= x) {
			map[i][j] = varr[idex++];
			--i;
			if (idex == varr.size()) return;
		}
		x++;
		y++;
		m--;
		n--;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值