poj 1094 Sorting It All Out 初级-》图算法-》拓扑排序

题意:一直到给定的第几条指令可以唯一确定一个拓扑排序的结果。 结果有三种:①、可以唯一确定;②、有环也就是矛盾;③、不能唯一确定也就是不能确定。 此题需要我们输入一条指令,执行一次拓扑排序。执行完一次拓扑排序后记得把入度再加回去。

 

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 22173Accepted: 7647

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

 

 

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<vector>
using namespace std;
vector <int> G[100];
stack<int>st1,st2;
int main()
{

    int n,m,i,j,k,len;
    int c1,c2,f1,f2,l1,l2,l3;
    int in[28];
    char ch[5],str[28];

    while(scanf("%d%d",&n,&m),n+m)
    {
      memset(in,0,sizeof(in));
      for(i=0;i<=n;i++) // 初始化
      G[i].clear();
      f1=0;
      for(i=1;i<=m;i++)
      {
        scanf("%s",ch);
        G[ch[0]-'A'].push_back(ch[2]-'A');
        in[ch[2]-'A']++;

        if(f1==0)
        {
          c1=0; f2=0; k=0;
          for(j=0;j<n;j++)
          if(in[j]==0)
          {
            st1.push(j);
            st2.push(j);
          }
          while(st1.size())
          {
            if(st1.size()>=2) f2=1;
            l1=st1.top();
            str[k++]=l1+'A';
            c1++; //记录一次拓扑排序后入度为零的点的个数
            st1.pop();
            len=G[l1].size();
            for(j=0;j<len;j++)
            {
              l2=G[l1][j];
              in[l2]--;
              if(in[l2]==0)
              {
                st1.push(l2);
                st2.push(l2);
              }
            }
          }
          if(c1!=n)
          {
            f1=1; c2=i;
          }
          else
          {
            if(c1==n&&f2==0)
            {
              f1=3; c2=i;
            }
            else if(i==m&&f2==1)
            {
              f1=2;
            }
          }
          while(st2.size())
          {
              l2=st2.top();
              st2.pop();
              len=G[l2].size();
              for(j=0;j<len;j++)
              {
                l3=G[l2][j];
                in[l3]++;
              }
          }
        }
      }
      if(f1==1)
      {
        cout<<"Inconsistency found after ";
        cout<<c2<<" relations."<<endl;
      }
      if(f1==2)
      {
        cout<<"Sorted sequence cannot be ";
        cout<<"determined."<<endl;
      }
      if(f1==3)
      {
        str[n]='\0';
        cout<<"Sorted sequence determined after";
        cout<<" "<<c2<<" relations: ";
        cout<<str<<"."<<endl;
      }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值