poj 1459 Power Network 初级->图算法->最大流(基本算法:增广路)

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 19197 Accepted: 10125

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6
 
 
BFS找增广路
 
 
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;

const int inf=10001;

vector<int> node[103];//记录和当前节点相连接的节点
struct node_1
{
    int pre; //当前节点的前驱节点
    int lv; //当前节点的容量
}node1[103];
int n,np,nc,line; //n个节点、np个发电站、nc个用户、line条边
int s,t; // 超级源点、超级汇点
int cap[103][103]; //弧(u,v)的容量
int flow[103][103]; //弧(u,v)的流量
bool vist[103]; //标记数组

int min(int a,int b)
{
    return a<b?a:b;
}

void back()
{
  int x=t;
  while(x!=s)
  {
    flow[node1[x].pre][x]+=node1[t].lv;//改进增广路
    x=node1[x].pre; //x变为其前驱节点,继续向s推进,直到修改到s结束
  }
}

bool bfs()
{
  queue<int> q;
  int i;
  memset(vist,false,sizeof(vist));
  node1[s].pre=-1;
  node1[s].lv=inf; //初值赋为无穷
  vist[s]=true;
  q.push(s);
  while(!q.empty())
  {
    int x,y;
    x=q.front();
    int SI=node[x].size();
    for(i=0;i<SI;i++)
    {
      y=node[x][i];
      if(!vist[y]&&flow[x][y]<cap[x][y])
      {
        q.push(y);
        vist[y]=true;
        node1[y].pre=x;
        node1[y].lv=min(node1[x].lv,cap[x][y]-flow[x][y]);
      }
      if(vist[t]) break;
    }
    if(!vist[t]) q.pop(); // 出队
    else return true;//找到一条增光路,返回true
  }
  return false; //如果队列空时也没有找到增光路,那么返回false
}

int main()
{
    int i,u,v,z,sum;
    char ch;
    while(cin>>n>>np>>nc>>line)
    {
      for(i=0;i<=102;i++) //容器初始化
      node[i].clear();
      s=n; t=n+1;
      for(i=1;i<=line;i++)
      {
        cin>>ch>>u>>ch>>v>>ch>>z;
        if(u==v) continue; //对环不进行处理
        cap[u][v]=z;
        flow[u][v]=0; // 每条边的流量都初始化为0
        node[u].push_back(v);
      }
      for(i=0;i<np;i++)
      {
        cin>>ch>>v>>ch>>z;
        cap[s][v]=z; //建立超级源点,指向所有电站
        flow[s][v]=0;
        node[s].push_back(v);
      }
      for(i=0;i<nc;i++)
      {
        cin>>ch>>u>>ch>>z;
        cap[u][t]=z; //建立超级汇点,被所有用户指向
        flow[u][t]=0;
        node[u].push_back(t);
      }

      for(;;) //找增广路
      if(bfs()) // 如果找到了增光路
        back(); // 就进行修改
      else
        break; // 直到找不到增广路退出循环

      sum=0; //初始化最大流
      int SI=node[s].size(); //和s相连接的节点的个数
      for(i=0;i<SI;i++)
      sum+=flow[s][node[s][i]]; //求和
      cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值