zoj 1610 Count the Colors(线段树:更新之后拍扁)

14 篇文章 0 订阅

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can’t be seen, you shouldn’t print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1
1 1

0 2
1 1

特么这题目我都看了半天才看懂……..实在是太抽象了,最后还是靠output猜的。问一波乱涂之后,还能看到多少块儿颜色(相邻同色算一块儿)。

区间问题,先一波update,把区间全部更新了再说。

然后就到了关键点…..数颜色。并没有想到好办法,于是只好把整棵树拍成线性,遍历一遍:

public static void query(int i, int l, int r) {
        if (l == r) {
            col[cnt++] = a[i];
            return;
        }
        pushDown(i);
        int mid = (l + r) / 2;
        query(i << 1, l, mid);
        query(i << 1 | 1, mid + 1, r);
    }

其实这个query是build写法,就是上上下下全跑一遍,然后拍成线性,顺便把没更新的lazy区间全更新了。

        for (int i = 0; i < cnt; i++) {
                int j = i + 1;
                if (col[i] != -1) {
                    ans[col[i]]++;
                }
                while (col[j] == col[i] && j < cnt) {
                    j++;
                }
                i = j - 1;
        }

接着数数有多少块儿,相邻的全部跳过跳过。

最后跑一次ans数组输出就好了….

ac代码:

public class Main {
    static final int MAX_N = 8010;
    static int cnt = 0;
    static int[] a = new int[MAX_N << 2];
    static int[] col = new int[MAX_N];
    static int[] ans = new int[MAX_N];

    public static void main(String[] args) {
        Scanner reader = new Scanner(System.in);
        //InputReader reader = new InputReader();
        PrintWriter out = new PrintWriter(System.out);
        int n = 0;
        while (reader.hasNext()) {
            n = reader.nextInt();
            Arrays.fill(a, -1);
            for (int i = 0; i < n; i++) {
                int x = reader.nextInt();
                int y = reader.nextInt();
                int cor = reader.nextInt();
                update(1, x, y - 1, 0, 8000, cor);
            }
            query(1, 0, 8000);
            for (int i = 0; i < cnt; i++) {
                int j = i + 1;
                if (col[i] != -1) {
                    ans[col[i]]++;
                }
                while (col[j] == col[i] && j < cnt) {
                    j++;
                }
                i = j - 1;
            }
            for (int i = 0; i < MAX_N; i++) {
                if (ans[i] > 0) {
                    out.println(i + " " + ans[i]);
                }
            }
            out.println();
            Arrays.fill(ans, 0);
            cnt = 0;
        }
        out.close();
    }

    public static void update(int i, int L, int R, int l, int r, int cor) {
        if (l >= L && r <= R) {
            a[i] = cor;
            return;
        }
        pushDown(i);
        int mid = (l + r) / 2;
        if (L <= mid) {
            update(i << 1, L, R, l, mid, cor);
        }
        if (R > mid) {
            update(i << 1 | 1, L, R, mid + 1, r, cor);
        }
    }

    public static void query(int i, int l, int r) {
        if (l == r) {
            col[cnt++] = a[i];
            return;
        }
        pushDown(i);
        int mid = (l + r) / 2;
        query(i << 1, l, mid);
        query(i << 1 | 1, mid + 1, r);
    }

    public static void pushDown(int i) {
        if (a[i] < 0) {
            return;
        }
        a[i << 1] = a[i << 1 | 1] = a[i];
        a[i] = -1;
    }
}

(吐槽:为什么zoj不给用输入挂= =,只要一加输入挂必submit fail,好几次了)

(吐槽2:这题给了2000ms,我一个java没用输入挂跑了417ms,数据太水了吧!)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值