KMP HDU1358&HDU3746 循环节&kmp

6 篇文章 0 订阅

KMP中循环节

 

考察一个具有循环节长为n的字符串,则循环节长为n-Next[n],且满足n%(n-Next[n])==0

反过来,满足上式,必有循环节。

 

不完全循环:

若n%(n-Next[n])!=0,也可能类似地存在错位、递推周期性相等的情况。 这时可能造成不完全循环。

不完全循环的周期依然为n-Next[n]

对于一个不完整的循环串要补充多少个才能使得其完整?

==>(循环节长度) - len%(循环节长度) 即 (len - Next[len]) - len%(len - Next[len])

 

其中原理,模拟一番便可感受到。

先考虑完全循环,如果到i位循环的话,自然i-Next[i]是它与前一匹配位的差,自然是前面循环的部分(注意,此时还要求,Next[i]>0),如果到这个i位是一个周期的结束的话,显然有n%(n-Next[n])==0。

接下来是不完全循环,但i为既在循环中,i-Next[i]依然是它的周期,多余出来的那一不完整周期的长度就是len%(len-Next[len])(周期),周期长度减去不完整周期即是需要添加的数目。

 

上题目:

 

HDU1358

 

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12431    Accepted Submission(s): 5825

 

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

Sample Input

3

aaa

12

aabaabaabaab

0

 

Sample Output

Test case #1

2 2

3 3

 

Test case #2

2 2

6 2

9 3

12 4

 

这道题问的是完全循环。

做的时候不知道循环节问题,还没看,机智地画图画出来了hiahiahia;然而PE了一发,因为愚蠢地没有仔细读输出格式要求。

 

#include <cstdio>
#include <cstring>

const int maxn=1000020;

int n;
char s[maxn];
int Next[maxn];
int ans[maxn][2];

void get_Next(char* s,int* Next)
{
	int m=strlen(s);
	Next[0]=Next[1]=0;
	for(int i=1;i<m;++i){
		int j=Next[i];
		while(j&&s[j]!=s[i]) j=Next[j];
		if(s[j]==s[i]) Next[i+1]=j+1;
		else Next[i+1]=0;
	}
}

int main()
{
	int cas=0;

	while(scanf("%d",&n)){
		if(!n) break;
		scanf("%s",s);
		get_Next(s,Next);
		printf("Test case #%d\n",++cas);
		for(int i=2;i<=n;++i){
			if(Next[i]&&i%(i-Next[i])==0){
				printf("%d %d\n",i,i/(i-Next[i]));
			}
		}
		printf("\n");
	}

	return 0;
}

 

HDU3746

 

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14407    Accepted Submission(s): 6015

 

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

 

Sample Input

3

aaa

abca

abcde

 

Sample Output

0

2

5

 

这道题就是问的不完全循环节,添加多少周期完整。

上面已经解释过了,直接上代码了:

 

#include <cstdio>
#include <cstring>

const int maxc=100020;

char s[maxc];
int Next[maxc];
int len;

void get_Next(char* s,int* Next)
{
	Next[0]=Next[1]=0;
	for(int i=1;i<len;++i){
		int j=Next[i];
		while(j&&s[i]!=s[j]) j=Next[j];
		if(s[i]==s[j]) Next[i+1]=j+1;
		else Next[i+1]=0;
	}
}

int main()
{
	int t;

	scanf("%d",&t);
	while(t--){
		scanf("%s",s);
		len=strlen(s);
		get_Next(s,Next);
		int p=len-Next[len];
		if(Next[len]&&len%p==0)
			printf("0\n");
		else{
			printf("%d\n",p-len%p);
		}
	}

	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值